aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-05-02 11:25:18 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-05-02 11:25:18 +0000
commit7f2743d45852d345f20809f1c24d1c197583b5d3 (patch)
tree0213d21e547b802857c28f3a62f689f74e8fc39e /package
parenta98cdd98927c6c7db2c0f9210c93bcca8cd618db (diff)
downloadupstream-7f2743d45852d345f20809f1c24d1c197583b5d3.tar.gz
upstream-7f2743d45852d345f20809f1c24d1c197583b5d3.tar.bz2
upstream-7f2743d45852d345f20809f1c24d1c197583b5d3.zip
kernel: netfilter.mk: Explicitly set the order of autoloaded modules
In my machine, the file is created with arptable_filter before arp_tables. This can't happen because the former depends on the latter. So, instead of rely on wildcards (*.ko), set by hand the files to be loaded in the correct order. Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br> SVN-Revision: 36512
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netfilter.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/netfilter.mk b/package/kernel/modules/netfilter.mk
index 50180a5f2c..4e4c85f45c 100644
--- a/package/kernel/modules/netfilter.mk
+++ b/package/kernel/modules/netfilter.mk
@@ -402,7 +402,7 @@ endef
$(eval $(call KernelPackage,ip6tables))
-
+ARP_MODULES = arp_tables arpt_mangle arptable_filter
define KernelPackage/arptables
SUBMENU:=$(NF_MENU)
TITLE:=ARP firewalling modules
@@ -410,7 +410,7 @@ define KernelPackage/arptables
KCONFIG:=CONFIG_IP_NF_ARPTABLES \
CONFIG_IP_NF_ARPFILTER \
CONFIG_IP_NF_ARP_MANGLE
- AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.ko))))
+ AUTOLOAD:=$(call AutoLoad,49,$(ARP_MODULES))
endef
define KernelPackage/arptables/description