aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-07-10 00:00:01 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-07-12 21:26:42 +0200
commit514a4b3e1b4e42fa796d1c908259ee9e215a77da (patch)
treed6d8d2720a5c7eebd2be5d36f8db2b66bf02fe2f /package
parent3e89f58a5ead1511f594704951946a79fc0b79d7 (diff)
downloadupstream-514a4b3e1b4e42fa796d1c908259ee9e215a77da.tar.gz
upstream-514a4b3e1b4e42fa796d1c908259ee9e215a77da.tar.bz2
upstream-514a4b3e1b4e42fa796d1c908259ee9e215a77da.zip
include/feeds.mk: rework generation of opkg distfeeds.conf
Allow enabling/commenting/disabling each feed individually by using a tristate config symbol. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> (cherry picked from commit 16035a7dd370671670693af9ae63368ee4dd731f)
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/image-config.in14
2 files changed, 0 insertions, 16 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index ef29798d5d..4842a45a41 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -25,8 +25,6 @@ PKG_CONFIG_DEPENDS += \
CONFIG_NAND_SUPPORT \
CONFIG_CLEAN_IPKG \
CONFIG_PER_FEED_REPO \
- CONFIG_PER_FEED_REPO_ADD_DISABLED \
- CONFIG_PER_FEED_REPO_ADD_COMMENTED \
$(foreach feed,$(FEEDS_AVAILABLE),CONFIG_FEED_$(feed))
include $(INCLUDE_DIR)/package.mk
diff --git a/package/base-files/image-config.in b/package/base-files/image-config.in
index 5ee2d3e4e3..cee8cd54e1 100644
--- a/package/base-files/image-config.in
+++ b/package/base-files/image-config.in
@@ -268,18 +268,4 @@ menuconfig PER_FEED_REPO
If set, a separate repository is generated within bin/*/packages/
for the core packages and each enabled feed.
- config PER_FEED_REPO_ADD_DISABLED
- bool "Add available but not enabled feeds to opkg.conf"
- default y
- depends on PER_FEED_REPO
- help
- Add not installed or disabled feeds from feeds.conf to opkg.conf.
-
- config PER_FEED_REPO_ADD_COMMENTED
- bool "Comment out not enabled feeds"
- default !BUILDBOT
- depends on PER_FEED_REPO && PER_FEED_REPO_ADD_DISABLED
- help
- Add not enabled feeds as commented out source lines to opkg.conf.
-
source "tmp/.config-feeds.in"