aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 13:26:33 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:26 +0100
commit96815fe0a2c1a7395d0e5aceba4a58e85ec32b41 (patch)
tree1d07941ee2fd9f905578dd7d31e3d32636ffb2dc /package
parent7ff7be96dd3491a4762a33c5b5062e5680a99849 (diff)
downloadupstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.tar.gz
upstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.tar.bz2
upstream-96815fe0a2c1a7395d0e5aceba4a58e85ec32b41.zip
kernel: remove omap24xx specific kernel module packages
If the target is ever restored, those drivers should be built into the kernel instead. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk32
-rw-r--r--package/kernel/linux/modules/spi.mk17
-rw-r--r--package/kernel/linux/modules/usb.mk39
3 files changed, 0 insertions, 88 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index adf3cc4069..017a94c622 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -114,22 +114,6 @@ endef
$(eval $(call KernelPackage,bluetooth_6lowpan))
-define KernelPackage/bluetooth-hci-h4p
- SUBMENU:=$(OTHER_MENU)
- TITLE:=HCI driver with H4 Nokia extensions
- DEPENDS:=@TARGET_omap24xx +kmod-bluetooth
- KCONFIG:=CONFIG_BT_HCIH4P
- FILES:=$(LINUX_DIR)/drivers/bluetooth/hci_h4p/hci_h4p.ko
- AUTOLOAD:=$(call AutoProbe,hci_h4p)
-endef
-
-define KernelPackage/bluetooth-hci-h4p/description
- HCI driver with H4 Nokia extensions
-endef
-
-$(eval $(call KernelPackage,bluetooth-hci-h4p))
-
-
define KernelPackage/dma-buf
SUBMENU:=$(OTHER_MENU)
TITLE:=DMA shared buffer support
@@ -482,22 +466,6 @@ endef
$(eval $(call KernelPackage,bcma))
-define KernelPackage/wdt-omap
- SUBMENU:=$(OTHER_MENU)
- TITLE:=OMAP Watchdog timer
- DEPENDS:=@TARGET_omap24xx
- KCONFIG:=CONFIG_OMAP_WATCHDOG
- FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,omap_wdt,1)
-endef
-
-define KernelPackage/wdt-omap/description
- Kernel module for TI omap watchdog timer
-endef
-
-$(eval $(call KernelPackage,wdt-omap))
-
-
define KernelPackage/rtc-ds1307
SUBMENU:=$(OTHER_MENU)
TITLE:=Dallas/Maxim DS1307 (and compatible) RTC support
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index 0b535a8cb4..1c2a789fed 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -89,20 +89,3 @@ define KernelPackage/spi-dev/description
endef
$(eval $(call KernelPackage,spi-dev))
-
-define KernelPackage/spi-omap-24xx
- SUBMENU:=$(SPI_MENU)
- TITLE:=SPI omap 24xx
- DEPENDS:=@TARGET_omap24xx
- KCONFIG:=CONFIG_SPI_OMAP24XX \
- CONFIG_SPI=y \
- CONFIG_SPI_MASTER=y
- FILES:=$(LINUX_DIR)/drivers/spi/spi-omap2-mcspi.ko
- AUTOLOAD:=$(call AutoProbe,spi-omap2-mcspi)
-endef
-
-define KernelPackage/spi-dev/description
- This package contains the user mode SPI device driver
-endef
-
-$(eval $(call KernelPackage,spi-omap-24xx))
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index f0d42a6751..4fe17f56ec 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -55,45 +55,6 @@ endef
$(eval $(call KernelPackage,usb-ledtrig-usbport))
-define KernelPackage/usb-musb-hdrc
- TITLE:=Support for Mentor Graphics silicon dual role USB
- KCONFIG:= \
- CONFIG_USB_MUSB_HDRC \
- CONFIG_USB_INVENTRA_DMA=n \
- CONFIG_USB_TI_CPPI41_DMA=n \
- CONFIG_MUSB_PIO_ONLY=y \
- CONFIG_USB_MUSB_DUAL_ROLE=y \
- CONFIG_USB_MUSB_GADGET=n \
- CONFIG_USB_MUSB_HOST=n \
- CONFIG_USB_MUSB_DEBUG=y
- DEPENDS:= \
- @TARGET_omap24xx +kmod-usb-gadget +kmod-usb-musb-tusb6010
- FILES:=$(LINUX_DIR)/drivers/usb/musb/musb_hdrc.ko
- AUTOLOAD:=$(call AutoLoad,46,musb_hdrc)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-musb-hdrc/description
- Kernel support for Mentor Graphics silicon dual role USB device.
-endef
-
-$(eval $(call KernelPackage,usb-musb-hdrc))
-
-
-define KernelPackage/usb-musb-tusb6010
- TITLE:=Support for TUSB 6010
- KCONFIG:=CONFIG_USB_MUSB_TUSB6010
- DEPENDS:=@TARGET_omap24xx
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-musb-tusb6010/description
- TUSB6010 support
-endef
-
-$(eval $(call KernelPackage,usb-musb-tusb6010))
-
-
define KernelPackage/usb-phy-nop
TITLE:=Support for USB NOP transceiver
KCONFIG:=CONFIG_NOP_USB_XCEIV