aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-03-01 10:48:32 -0800
committerJo-Philipp Wich <jo@mein.io>2017-04-22 12:43:51 +0200
commit72fcdb6286ad7be24296acbd36043ee3e96e5ec4 (patch)
treeb9106309d8d6e5bbd733613835204b15f2b6ce68 /package
parent5feb4f0e6d9e686c9b2d3d406a7f348137baf0dc (diff)
downloadupstream-72fcdb6286ad7be24296acbd36043ee3e96e5ec4.tar.gz
upstream-72fcdb6286ad7be24296acbd36043ee3e96e5ec4.tar.bz2
upstream-72fcdb6286ad7be24296acbd36043ee3e96e5ec4.zip
openssl: Use mkhash for STAMP_CONFIGURED
The current way of creating a STAMP_CONFIGURED filename for OpenSSL can lead to an extremely long filename that makes touch unable to create it, and fail the build. Use mkhash to produce a hash against OPENSSL_OPTIONS which creates a shortert stamp file, Fixes #572 Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/libs/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 9b6430234e..b39e3c6d7a 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -168,7 +168,7 @@ else
endif
endif
-STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(shell echo $(OPENSSL_OPTIONS) | mkhash md5)
define Build/Configure
[ -f $(STAMP_CONFIGURED) ] || { \