aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2012-08-09 13:13:26 +0000
committerJonas Gorski <jogo@openwrt.org>2012-08-09 13:13:26 +0000
commitf1a4e36531adf2ae9ece443236096c4eebcb16f4 (patch)
tree46bd5f74847d275fc5466b3e05911df943dce038 /package
parentf955432959ed7aae03b4ed38717ec0c24c93053c (diff)
downloadupstream-f1a4e36531adf2ae9ece443236096c4eebcb16f4.tar.gz
upstream-f1a4e36531adf2ae9ece443236096c4eebcb16f4.tar.bz2
upstream-f1a4e36531adf2ae9ece443236096c4eebcb16f4.zip
package: linux-atm: br2684ct: fix nas interface bringup on boot
Give nas interface time to setup them selves before configuring them. Should fix #11826. Contributed by T-Labs, Deutsche Telekom Innovation Laboratories Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33074 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/linux-atm/Makefile2
-rwxr-xr-xpackage/linux-atm/files/br2684ctl10
2 files changed, 10 insertions, 2 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 1ac0a219a2..4543f7aca4 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=linux-atm
PKG_VERSION:=2.5.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
diff --git a/package/linux-atm/files/br2684ctl b/package/linux-atm/files/br2684ctl
index b2199e6307..cd53f0481b 100755
--- a/package/linux-atm/files/br2684ctl
+++ b/package/linux-atm/files/br2684ctl
@@ -1,5 +1,8 @@
#!/bin/sh /etc/rc.common
+
+. /lib/functions/network.sh
+
START=50
SERVICE_DAEMONIZE=1
@@ -43,11 +46,16 @@ start_daemon() {
config_get sendsize "$cfg" sendsize
local circuit="$atmdev.$vpi.$vci"
-
+
+ network_defer_device "nas$unit"
+
SERVICE_PID_FILE="/var/run/br2684ctl-$circuit.pid" \
service_start /usr/sbin/br2684ctl \
-c "$unit" -e "$encaps" -p "$payload" \
-a "$circuit" ${qos:+-q "$qos"} ${sendsize:+-s "$sendsize"}
+ sleep 1
+
+ network_ready_device "nas$unit"
}
stop_daemon() {