aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-13 21:25:03 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:22:07 +0100
commitfd211e1677fc653feeef6b0b8b8e8659ac274b3c (patch)
tree7461e06afc5b95884e8004e33eea5b7c9a13b1a0 /package
parent6041eb9547be49edaa6c2ecd5dd77e8a9e067244 (diff)
downloadupstream-fd211e1677fc653feeef6b0b8b8e8659ac274b3c.tar.gz
upstream-fd211e1677fc653feeef6b0b8b8e8659ac274b3c.tar.bz2
upstream-fd211e1677fc653feeef6b0b8b8e8659ac274b3c.zip
iperf: Fix compilation with libcxx
Avoids redefining bool. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iperf/Makefile2
-rw-r--r--package/network/utils/iperf/patches/010-libcxx.patch12
2 files changed, 13 insertions, 1 deletions
diff --git a/package/network/utils/iperf/Makefile b/package/network/utils/iperf/Makefile
index 33d00b43d7..3a235fadc7 100644
--- a/package/network/utils/iperf/Makefile
+++ b/package/network/utils/iperf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=iperf
PKG_VERSION:=2.0.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_HASH:=c88adec966096a81136dda91b4bd19c27aae06df4d45a7f547a8e50d723778ad
diff --git a/package/network/utils/iperf/patches/010-libcxx.patch b/package/network/utils/iperf/patches/010-libcxx.patch
new file mode 100644
index 0000000000..cf0124232f
--- /dev/null
+++ b/package/network/utils/iperf/patches/010-libcxx.patch
@@ -0,0 +1,12 @@
+--- a/config.h.in
++++ b/config.h.in
+@@ -360,7 +360,9 @@
+ #undef _REENTRANT
+
+ /* */
++#ifndef __cplusplus
+ #undef bool
++#endif
+
+ /* Define to empty if `const' does not conform to ANSI C. */
+ #undef const