aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-08-25 18:11:03 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-08-25 18:18:35 +0200
commite882e63f1e1169030389b304489ab8a7d785df33 (patch)
treea9d928996eb5af00e91845bd078b4e4cf444b33b /package
parent5dd745588edea19846b2bc3a2e6938f139374ea9 (diff)
downloadupstream-e882e63f1e1169030389b304489ab8a7d785df33.tar.gz
upstream-e882e63f1e1169030389b304489ab8a7d785df33.tar.bz2
upstream-e882e63f1e1169030389b304489ab8a7d785df33.zip
kernel: add missing dependency to regmap to kmod-gpio-mcp23s08
This fixes a build problem recently introduced. Fixes: a904003b9b5f ("kernel: fix kmod-gpio-mcp23s08 for linux 4.14") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 279c159878..7df93d3a01 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -227,7 +227,7 @@ $(eval $(call KernelPackage,gpio-dev))
define KernelPackage/gpio-mcp23s08
SUBMENU:=$(OTHER_MENU)
TITLE:=Microchip MCP23xxx I/O expander
- DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core
+ DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +LINUX_4_14:kmod-regmap
KCONFIG:= \
CONFIG_GPIO_MCP23S08 \
CONFIG_PINCTRL_MCP23S08