aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-20 17:06:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-20 17:06:51 +0000
commite06d472f3f8c885c29da892fe382ba60cc3ae161 (patch)
tree09e100c40db848e930159c4b24dad01569694fb4 /package
parenta3349d379590ba15e66aa28bb7964fe2fe6df59f (diff)
downloadupstream-e06d472f3f8c885c29da892fe382ba60cc3ae161.tar.gz
upstream-e06d472f3f8c885c29da892fe382ba60cc3ae161.tar.bz2
upstream-e06d472f3f8c885c29da892fe382ba60cc3ae161.zip
fix a typo in the compat-wireless build speedup patch
SVN-Revision: 17337
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/patches/001-speedup_build.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/mac80211/patches/001-speedup_build.patch b/package/mac80211/patches/001-speedup_build.patch
index 6f4c3d113e..82d73f8bd4 100644
--- a/package/mac80211/patches/001-speedup_build.patch
+++ b/package/mac80211/patches/001-speedup_build.patch
@@ -14,8 +14,8 @@
-KERNEL_SUBLEVEL = $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^2\.6\.\([0-9]\+\).*/\1/p')
+ifneq ($(wildcard $(KLIB_BUILD)/Makefile),)
+COMPAT_LATEST_VERSION = 32
-+KERNEL_SUBLEVEL ?= $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^2\.6\.\([0-9]\+\).*/\1/p')
-+COMPAT_VERSIONS ?= $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
++KERNEL_SUBLEVEL := $(shell $(MAKE) -C $(KLIB_BUILD) kernelversion | sed -n 's/^2\.6\.\([0-9]\+\).*/\1/p')
++COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
+$(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_WIRELESS_$(ver)=y))
-ifeq ($(shell test $(KERNEL_SUBLEVEL) -lt 25 && echo yes),yes)
@@ -86,7 +86,7 @@
ifneq ($(CONFIG_PCMCIA),)
-ifeq ($(shell test $(KERNEL_SUBLEVEL) -le 26 && echo yes),yes)
-+ifdef CONFIG_COMPAT_WIRELESS_25
++ifdef CONFIG_COMPAT_WIRELESS_27
CONFIG_LIBERTAS=n
CONFIG_LIBERTAS_CS=n
else