aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-03-04 19:37:43 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-02 22:42:36 +0800
commitcfa58651872f6f7b5cb3fa6897883891d1b28617 (patch)
tree0618fca186d06145999250afed016d4604c4c390 /package
parent8b1b094fefc41342e70a7cb498d5bcceef89abce (diff)
downloadupstream-cfa58651872f6f7b5cb3fa6897883891d1b28617.tar.gz
upstream-cfa58651872f6f7b5cb3fa6897883891d1b28617.tar.bz2
upstream-cfa58651872f6f7b5cb3fa6897883891d1b28617.zip
iproute2: add ip-tiny, ip-full as alternatives of /sbin/ip
They will not be in conflict anymore ;) Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iproute2/Makefile26
1 files changed, 16 insertions, 10 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index 0fa88b674d..fd6b5683e0 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -22,23 +22,29 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSI
include $(INCLUDE_DIR)/package.mk
define Package/iproute2/Default
- TITLE:=Routing control utility ($(2))
SECTION:=net
CATEGORY:=Network
URL:=http://www.linuxfoundation.org/collaborate/workgroups/networking/iproute2
SUBMENU:=Routing and Redirection
MAINTAINER:=Russell Senior <russell@personaltelco.net>
DEPENDS:= +libnl-tiny
- VARIANT:=$(1)
- PROVIDES:=$(3)
endef
define Package/ip-tiny
-$(call Package/iproute2/Default,tiny,Minimal,ip)
- CONFLICTS:=ip-full
+$(call Package/iproute2/Default)
+ TITLE:=Routing control utility (Minimal)
+ VARIANT:=tiny
+ PROVIDES:=ip
+ ALTERNATIVES:=200:/sbin/ip:/sbin/ip-tiny
endef
-Package/ip-full:=$(call Package/iproute2/Default,full,Full,ip)
+define Package/ip-full
+$(call Package/iproute2/Default)
+ TITLE:=Routing control utility (Full)
+ VARIANT:=full
+ PROVIDES:=ip
+ ALTERNATIVES:=300:/sbin/ip:/sbin/ip-full
+endef
define Package/tc
$(call Package/iproute2/Default)
@@ -103,13 +109,13 @@ define Build/InstallDev
endef
define Package/ip-tiny/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/sbin/ip-tiny
endef
define Package/ip-full/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/ip/ip $(1)/sbin/ip-full
endef
define Package/tc/install