aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:01:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-04 21:01:24 +0000
commitcb232921b57bce6d04a30deee53205a0039bb368 (patch)
tree33b89b948bbb46791284eb880fb167b70d8b8c2c /package
parent0ff83e90ba5f0ed1d900813b470f61527500fdd8 (diff)
downloadupstream-cb232921b57bce6d04a30deee53205a0039bb368.tar.gz
upstream-cb232921b57bce6d04a30deee53205a0039bb368.tar.bz2
upstream-cb232921b57bce6d04a30deee53205a0039bb368.zip
kernel: package ocf hifn7751 and hifnHIPP drivers, allow OCF on brcm-2.4
SVN-Revision: 21358
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/crypto.mk26
1 files changed, 25 insertions, 1 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 7c6835135d..49f2e45f43 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -293,7 +293,7 @@ $(eval $(call KernelPackage,crypto-misc))
define KernelPackage/crypto-ocf
TITLE:=OCF modules
- DEPENDS:=@LINUX_2_6 +@OPENSSL_ENGINE @!TARGET_uml
+ DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml
KCONFIG:= \
CONFIG_OCF_OCF \
CONFIG_OCF_CRYPTODEV \
@@ -315,6 +315,30 @@ endef
$(eval $(call KernelPackage,crypto-ocf))
+define KernelPackage/crypto-ocf-hifn7751
+ TITLE:=OCF support for Hifn 6500/7751/7811/795x, Invertex AEON and NetSec 7751 devices
+ DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml kmod-crypto-ocf
+ KCONFIG:=CONFIG_OCF_HIFN
+ FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifn7751.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,10,hifn7751)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ocf-hifn7751))
+
+
+define KernelPackage/crypto-ocf-hifnhipp
+ TITLE:=OCF support for Hifn 7855/8155 devices
+ DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml kmod-crypto-ocf
+ KCONFIG:=CONFIG_OCF_HIFNHIPP
+ FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifnHIPP.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,10,hifnhipp)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ocf-hifnhipp))
+
+
define KernelPackage/crypto-null
TITLE:=Null CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_NULL