aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-01-31 13:32:03 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-28 17:50:46 +0100
commitc4437d4e084f17320a21a1647d80d6491972c66d (patch)
tree0e6d6a8a16c7cea40a3305379a8be5cdc9fb545d /package
parent0fad8af85158171efda679cdd49fd7fa4d515ee9 (diff)
downloadupstream-c4437d4e084f17320a21a1647d80d6491972c66d.tar.gz
upstream-c4437d4e084f17320a21a1647d80d6491972c66d.tar.bz2
upstream-c4437d4e084f17320a21a1647d80d6491972c66d.zip
kernel: Add crypto libraries to modules
In kernel 5.3 and 5.4 some crypto modules were split into two modules, one implementing the crypto algorithm and the other integrating it into the Linux crypto framework. Adapt OpenWrt to support this split. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/crypto.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 26873b404a..be2182fd8b 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -169,7 +169,9 @@ $(eval $(call KernelPackage,crypto-deflate))
define KernelPackage/crypto-des
TITLE:=DES/3DES cipher CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_DES
- FILES:=$(LINUX_DIR)/crypto/des_generic.ko
+ FILES:= \
+ $(LINUX_DIR)/crypto/des_generic.ko \
+ $(LINUX_DIR)/lib/crypto/libdes.ko@ge5.4
AUTOLOAD:=$(call AutoLoad,09,des_generic)
$(call AddDepends/crypto)
endef
@@ -194,7 +196,8 @@ define KernelPackage/crypto-ecdh
DEPENDS:=+kmod-crypto-kpp
KCONFIG:= CONFIG_CRYPTO_ECDH
FILES:= \
- $(LINUX_DIR)/crypto/ecdh_generic.ko
+ $(LINUX_DIR)/crypto/ecdh_generic.ko \
+ $(LINUX_DIR)/crypto/ecc.ko@ge5.2
AUTOLOAD:=$(call AutoLoad,10,ecdh_generic)
$(call AddDepends/crypto)
endef
@@ -695,7 +698,9 @@ define KernelPackage/crypto-sha256
CONFIG_CRYPTO_SHA256 \
CONFIG_CRYPTO_SHA256_OCTEON \
CONFIG_CRYPTO_SHA256_SSSE3
- FILES:=$(LINUX_DIR)/crypto/sha256_generic.ko
+ FILES:= \
+ $(LINUX_DIR)/crypto/sha256_generic.ko \
+ $(LINUX_DIR)/lib/crypto/libsha256.ko@ge5.4
AUTOLOAD:=$(call AutoLoad,09,sha256_generic)
$(call AddDepends/crypto)
endef