aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJonas Gorski <jonas.gorski@gmail.com>2017-04-10 10:56:10 +0200
committerJonas Gorski <jonas.gorski@gmail.com>2017-04-10 11:23:51 +0200
commitac388ad83ae39c6871958d9092d6225be45f9ceb (patch)
tree2d44c170b64e735937f20349e8d88304c1c5cd45 /package
parentfc859fb44b4e7a38a1f1825b05b72b81e80f82a8 (diff)
downloadupstream-ac388ad83ae39c6871958d9092d6225be45f9ceb.tar.gz
upstream-ac388ad83ae39c6871958d9092d6225be45f9ceb.tar.bz2
upstream-ac388ad83ae39c6871958d9092d6225be45f9ceb.zip
kernel: make kmod-mmc unavailable on UML
MMC requires IOMEM support, which UML doesn't have. Fixes mac80211 build, as mwifiex-sdio depends on MMC support. Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b8b22411b2..e7e98e8daa 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -349,6 +349,7 @@ $(eval $(call KernelPackage,lp))
define KernelPackage/mmc
SUBMENU:=$(OTHER_MENU)
TITLE:=MMC/SD Card Support
+ DEPENDS:=@!TARGET_uml
KCONFIG:= \
CONFIG_MMC \
CONFIG_MMC_BLOCK \