aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-16 18:17:51 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-16 18:17:51 +0000
commita258b442f4902a2d676a5646beefef1d0c0fda9b (patch)
tree020c53d907bb1b03f4cbf146466bfa82a0ea9a6c /package
parente3a7ac074ac7cd89777299e7eba2c71f937d9e76 (diff)
downloadupstream-a258b442f4902a2d676a5646beefef1d0c0fda9b.tar.gz
upstream-a258b442f4902a2d676a5646beefef1d0c0fda9b.tar.bz2
upstream-a258b442f4902a2d676a5646beefef1d0c0fda9b.zip
Move back pciutils to utils, and haserl in the meantime
SVN-Revision: 8006
Diffstat (limited to 'package')
-rw-r--r--package/haserl/Makefile33
-rw-r--r--package/haserl/patches/100-cookie_prefix.patch21
-rw-r--r--package/pciutils/Makefile74
3 files changed, 0 insertions, 128 deletions
diff --git a/package/haserl/Makefile b/package/haserl/Makefile
deleted file mode 100644
index aa0413e25e..0000000000
--- a/package/haserl/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=haserl
-PKG_VERSION:=0.8.0
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/haserl
-PKG_MD5SUM:=bd9195d086566f56634c0bcbbbcbebea
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/haserl
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=A CGI wrapper to embed shell scripts in HTML documents
- URL:=http://haserl.sourceforge.net/
-endef
-
-define Package/haserl/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,haserl))
diff --git a/package/haserl/patches/100-cookie_prefix.patch b/package/haserl/patches/100-cookie_prefix.patch
deleted file mode 100644
index ba91fe690d..0000000000
--- a/package/haserl/patches/100-cookie_prefix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Index: haserl-0.8.0/src/haserl.c
-===================================================================
---- haserl-0.8.0.orig/src/haserl.c 2007-06-04 13:22:30.973146648 +0200
-+++ haserl-0.8.0/src/haserl.c 2007-06-04 13:22:31.039136616 +0200
-@@ -74,6 +74,7 @@
- token_t /*@null@*/ *token_list = NULL;
-
- char global_variable_prefix[] = HASERL_VAR_PREFIX;
-+char cookie_variable_prefix[] = "COOKIE_";
- int global_subshell_pipe[4];
- int global_subshell_pid;
- int global_subshell_died = 0;
-@@ -221,7 +222,7 @@
- while (token) {
- // skip leading spaces
- while ( token[0] == ' ' ) { token++; }
-- myputenv(token, global_variable_prefix);
-+ myputenv(token, cookie_variable_prefix);
- token=strtok(NULL, ";");
- }
- free (qs);
diff --git a/package/pciutils/Makefile b/package/pciutils/Makefile
deleted file mode 100644
index ec404aa4a1..0000000000
--- a/package/pciutils/Makefile
+++ /dev/null
@@ -1,74 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=pciutils
-PKG_VERSION:=2.2.1
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.kernel.org/pub/software/utils/pciutils/ \
- ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
-PKG_MD5SUM:=c18e2a5f04e9abae5a42439de294f086
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/pciutils
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Linux PCI Utilities
- DESCRIPTION:=\
- This package contains various utilities for inspecting and setting of \\\
- devices connected to the PCI bus.
- URL:=http://www.kernel.org/pub/software/utils/pciutils/
-endef
-
-define Package/pciutils/postinst
-#!/bin/sh
-$${IPKG_INSTROOT}/usr/sbin/update-pciids.sh
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(call Build/Compile/Default, \
- CFLAGS="$(TARGET_CFLAGS)" \
- IDSDIR="/usr/share" \
- HOST="$(GNU_TARGET_NAME)" \
- )
-endef
-
-define Build/InstallDev
- $(INSTALL_DIR) $(STAGING_DIR)/usr/lib
- $(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(STAGING_DIR)/usr/lib
- $(INSTALL_DIR) $(STAGING_DIR)/usr/include/pci
- $(CP) $(PKG_BUILD_DIR)/lib/pci.h $(STAGING_DIR)/usr/include/pci
- $(CP) $(PKG_BUILD_DIR)/lib/config.h $(STAGING_DIR)/usr/include/pci
- $(CP) $(PKG_BUILD_DIR)/lib/header.h $(STAGING_DIR)/usr/include/pci
- $(CP) $(PKG_BUILD_DIR)/lib/types.h $(STAGING_DIR)/usr/include/pci
-endef
-
-define Build/UninstallDev
- rm -rf \
- $(STAGING_DIR)/usr/include/pci \
- $(STAGING_DIR)/usr/lib/libpci.a
-endef
-
-define Package/pciutils/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/{lspci,setpci,update-pciids.sh} $(1)/usr/sbin/
- $(INSTALL_DIR) $(1)/usr/share
- $(CP) $(PKG_BUILD_DIR)/pci.ids $(1)/usr/share/
-endef
-
-$(eval $(call BuildPackage,pciutils))