aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-26 01:03:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-26 01:03:21 +0000
commit97b0e81658a4c8acc38024584e867d6174de1042 (patch)
tree4c904f1657df52df2df912bd509529ba4416cd9d /package
parentd94301a65f65585f3cfa81f8c3e58a1641add5fa (diff)
downloadupstream-97b0e81658a4c8acc38024584e867d6174de1042.tar.gz
upstream-97b0e81658a4c8acc38024584e867d6174de1042.tar.bz2
upstream-97b0e81658a4c8acc38024584e867d6174de1042.zip
add reboot fix for mtd (thanks, wbx)
SVN-Revision: 5645
Diffstat (limited to 'package')
-rw-r--r--package/mtd/Makefile2
-rw-r--r--package/mtd/src/mtd.c12
2 files changed, 9 insertions, 5 deletions
diff --git a/package/mtd/Makefile b/package/mtd/Makefile
index 8444bd8029..cf23fbeebc 100644
--- a/package/mtd/Makefile
+++ b/package/mtd/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mtd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
diff --git a/package/mtd/src/mtd.c b/package/mtd/src/mtd.c
index 80d09abd2a..7d1e36010c 100644
--- a/package/mtd/src/mtd.c
+++ b/package/mtd/src/mtd.c
@@ -28,17 +28,20 @@
#include <stdlib.h>
#include <stdio.h>
#include <stdint.h>
+#include <sys/ioctl.h>
+#include <sys/syscall.h>
#include <fcntl.h>
#include <errno.h>
#include <error.h>
#include <time.h>
+#include <string.h>
#include <sys/ioctl.h>
#include <sys/types.h>
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/stat.h>
#include <sys/reboot.h>
-#include <string.h>
+#include <linux/reboot.h>
#include "mtd.h"
@@ -458,8 +461,9 @@ int main (int argc, char **argv)
sync();
- if (boot)
- kill(1, 15); // send SIGTERM to init for reboot
-
+ if (boot) {
+ fflush(stdout);
+ syscall(SYS_reboot,LINUX_REBOOT_MAGIC1,LINUX_REBOOT_MAGIC2,LINUX_REBOOT_CMD_RESTART,NULL);
+ }
return 0;
}