aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-27 21:21:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-27 21:21:28 +0000
commit7ce91a64f0c560cecd0980e7b457f72b0a5ef403 (patch)
treef5e140cce288ac5cf1eb1155bca78c967aade6e7 /package
parent536a4ce5b979c466a1c97ec448dd7210eb9248f5 (diff)
downloadupstream-7ce91a64f0c560cecd0980e7b457f72b0a5ef403.tar.gz
upstream-7ce91a64f0c560cecd0980e7b457f72b0a5ef403.tar.bz2
upstream-7ce91a64f0c560cecd0980e7b457f72b0a5ef403.zip
mac80211: fix a typo in the mac80211.sh
SVN-Revision: 18567
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/Makefile2
-rw-r--r--package/mac80211/files/lib/wifi/mac80211.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 6fb2b23141..9440ca6a18 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2009-11-21
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:= \
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/11 \
http://wireless.kernel.org/download/compat-wireless-2.6
diff --git a/package/mac80211/files/lib/wifi/mac80211.sh b/package/mac80211/files/lib/wifi/mac80211.sh
index 591d978da3..b7984a3b7f 100644
--- a/package/mac80211/files/lib/wifi/mac80211.sh
+++ b/package/mac80211/files/lib/wifi/mac80211.sh
@@ -309,7 +309,7 @@ detect_mac80211() {
[ "$ht_cap" -gt 0 ] && {
mode_11n="n"
list=" list ht_capab"
- [ "$(($ht_cap & 2))" -eq 1 ] && append ht_capab "$list LDPC" "$N"
+ [ "$(($ht_cap & 1))" -eq 1 ] && append ht_capab "$list LDPC" "$N"
[ "$(($ht_cap & 2))" -eq 2 ] && append ht_capab "$list HT40-" "$N"
[ "$(($ht_cap & 32))" -eq 32 ] && append ht_capab "$list SHORT-GI-20" "$N"
[ "$(($ht_cap & 64))" -eq 64 ] && append ht_capab "$list SHORT-GI-40" "$N"