aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-09-16 10:32:42 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-09-16 10:32:42 +0000
commit5adf1705973ca26d67b5b727202c7fbe8c6c49b6 (patch)
tree99863340386a21344b79bc8e3e8ea13b1cb03b8f /package
parent9dfd1faee36f3af57bb878f042c1a6821e70c27c (diff)
downloadupstream-5adf1705973ca26d67b5b727202c7fbe8c6c49b6.tar.gz
upstream-5adf1705973ca26d67b5b727202c7fbe8c6c49b6.tar.bz2
upstream-5adf1705973ca26d67b5b727202c7fbe8c6c49b6.zip
Package wpa-passphrase (#1275)
SVN-Revision: 8788
Diffstat (limited to 'package')
-rw-r--r--package/wpa_supplicant/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/wpa_supplicant/Makefile b/package/wpa_supplicant/Makefile
index 6448145565..a90196868c 100644
--- a/package/wpa_supplicant/Makefile
+++ b/package/wpa_supplicant/Makefile
@@ -27,7 +27,6 @@ define Package/wpa-supplicant
URL:=http://hostap.epitest.fi/wpa_supplicant/
endef
-
define Package/wpa-cli
SECTION:=net
CATEGORY:=Network
@@ -36,6 +35,13 @@ define Package/wpa-cli
DESCRIPTION:=
endef
+define Package/wpa-passphrase
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=wpa-supplicant
+ TITLE:=Set WPA passphrase for a SSID
+ DESCRIPTION:=
+endef
define Build/Configure
cp ./files/config.$(ARCH) $(PKG_BUILD_DIR)/.config
@@ -65,5 +71,11 @@ define Package/wpa-cli/install
$(CP) $(PKG_BUILD_DIR)/wpa_cli $(1)/usr/sbin/
endef
+define Package/wpa-passphrase/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/wpa_passphrase $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,wpa-supplicant))
$(eval $(call BuildPackage,wpa-cli))
+$(eval $(call BuildPackage,wpa-passphrase))