aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-02-23 16:46:01 +0100
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2020-02-28 17:50:46 +0100
commit34fcdcd7c2fb81fddd14292193ef2a42ba958a3a (patch)
tree0941c082d00261c1e1ea88d34cbc1a0a8f0a5b5c /package
parentf1ff9410f6becb3ba50c5679e75502b45e0a63d7 (diff)
downloadupstream-34fcdcd7c2fb81fddd14292193ef2a42ba958a3a.tar.gz
upstream-34fcdcd7c2fb81fddd14292193ef2a42ba958a3a.tar.bz2
upstream-34fcdcd7c2fb81fddd14292193ef2a42ba958a3a.zip
kernel: Remove nvmem hack patch from 5.4
The nvmem framework is now used in net/ethernet/eth.c and the nvmem sysfs is split into a separate Kconfig option. More work would be needed to adapt this patch for the broader use. The current patch compiles fine on ath79, but it breaks the x86 target. nvmem is also compiled into the kernel for most of our targets for example ath79 anyway, so patching the kernel to remove it is now harder and not the case on multiple targets anyway. Instead of making this work on kernel 5.4 just remove this hack patch. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 7e8301f278..147ad99cd1 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -139,6 +139,7 @@ $(eval $(call KernelPackage,dma-buf))
define KernelPackage/nvmem
SUBMENU:=$(OTHER_MENU)
TITLE:=Non Volatile Memory support
+ DEPENDS:=@!LINUX_5_4
KCONFIG:=CONFIG_NVMEM
HIDDEN:=1
FILES:=$(LINUX_DIR)/drivers/nvmem/nvmem_core.ko
@@ -169,7 +170,7 @@ define KernelPackage/eeprom-at24
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM AT24 support
KCONFIG:=CONFIG_EEPROM_AT24
- DEPENDS:=+kmod-i2c-core +kmod-nvmem +!LINUX_4_14:kmod-regmap-i2c
+ DEPENDS:=+kmod-i2c-core +!LINUX_5_4:kmod-nvmem +!LINUX_4_14:kmod-regmap-i2c
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at24.ko
AUTOLOAD:=$(call AutoProbe,at24)
endef
@@ -185,7 +186,7 @@ define KernelPackage/eeprom-at25
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM AT25 support
KCONFIG:=CONFIG_EEPROM_AT25
- DEPENDS:=+kmod-nvmem
+ DEPENDS:=+!LINUX_5_4:kmod-nvmem
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at25.ko
AUTOLOAD:=$(call AutoProbe,at25)
endef