aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-04-24 09:49:03 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-04-24 09:49:03 +0000
commit2cea3d3949996b0618a098cd5cd86e24d95f24ab (patch)
treea17745a2e7c9101e7813d61036a8f6312ffaa997 /package
parent2dbcd2ba7b582ecef5d065e887790cff6af33715 (diff)
downloadupstream-2cea3d3949996b0618a098cd5cd86e24d95f24ab.tar.gz
upstream-2cea3d3949996b0618a098cd5cd86e24d95f24ab.tar.bz2
upstream-2cea3d3949996b0618a098cd5cd86e24d95f24ab.zip
Add kernel module package for hid-generic driver.
Needed to support e.g. keyboards and mice. Signed-off-by: Danny Baumann <dannybaumann@web.de> SVN-Revision: 36414
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/input.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/input.mk b/package/kernel/modules/input.mk
index d3c1b34e65..89575ae783 100644
--- a/package/kernel/modules/input.mk
+++ b/package/kernel/modules/input.mk
@@ -22,6 +22,20 @@ endef
$(eval $(call KernelPackage,hid))
+define KernelPackage/hid-generic
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=Generic HID device support
+ KCONFIG:=CONFIG_HID_GENERIC
+ FILES:=$(LINUX_DIR)/drivers/hid/hid-generic.ko
+ AUTOLOAD:=$(call AutoLoad,62,hid-generic)
+ $(call AddDepends/hid)
+endef
+
+define KernelPackage/hid/description
+ Kernel modules for generic HID device (e.g. keyboards and mice) support
+endef
+
+$(eval $(call KernelPackage,hid-generic))
define KernelPackage/input-core
SUBMENU:=$(INPUT_MODULES_MENU)