aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-18 11:49:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-18 11:49:10 +0000
commit2a4481b95c9f6d165757c6503b1c768ec5ff9634 (patch)
tree842e79ffdad8a4274962afa9ef58a7bb3b5c144c /package
parent8e4255397198574a9cd1354e194cb65bdd2051c0 (diff)
downloadupstream-2a4481b95c9f6d165757c6503b1c768ec5ff9634.tar.gz
upstream-2a4481b95c9f6d165757c6503b1c768ec5ff9634.tar.bz2
upstream-2a4481b95c9f6d165757c6503b1c768ec5ff9634.zip
fix a kconfig usage bug
SVN-Revision: 8027
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/usb.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index 636984a0b5..573398e481 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -50,17 +50,14 @@ define KernelPackage/usb-uhci
$(call usbdep,)
TITLE:=Support for UHCI controllers
DESCRIPTION:=Kernel support for USB UHCI controllers
+ KCONFIG:=CONFIG_USB_UHCI_ALT CONFIG_USB_UHCI_HCD
endef
-
define KernelPackage/usb-uhci/2.4
FILES:=$(LINUX_DIR)/drivers/usb/host/uhci.o
- KCONFIG:=CONFIG_USB_UHCI_ALT
AUTOLOAD:=$(call AutoLoad,50,uhci)
endef
-
define KernelPackage/usb-uhci/2.6
FILES:=$(LINUX_DIR)/drivers/usb/host/uhci-hcd.ko
- KCONFIG:=CONFIG_USB_UHCI_HCD
AUTOLOAD:=$(call AutoLoad,50,uhci-hcd)
endef
$(eval $(call KernelPackage,usb-uhci))