aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-15 18:19:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-15 18:19:57 +0000
commit160c2ef0118472b7178d432216ee10aa2df48fe1 (patch)
tree5a05cc2a58726979c8c1fc77aa96ecae521d40cf /package
parent0f6e5b76f8aac652a2ee9ff274ee0d5d3e632921 (diff)
downloadupstream-160c2ef0118472b7178d432216ee10aa2df48fe1.tar.gz
upstream-160c2ef0118472b7178d432216ee10aa2df48fe1.tar.bz2
upstream-160c2ef0118472b7178d432216ee10aa2df48fe1.zip
uhttpd: update to latest git head - introduces support for multiple index files - fixes build with only the TLS module selected
SVN-Revision: 33778
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile4
-rwxr-xr-xpackage/network/services/uhttpd/files/uhttpd.init8
2 files changed, 8 insertions, 4 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index b2f0879ea0..555d50c3f2 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_VERSION:=2012-10-15
+PKG_VERSION:=2012-10-15.2
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/uhttpd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fa43d1a62864f912e4450affb9c86f3accbe026a
+PKG_SOURCE_VERSION:=d42932f9da6584c10d5d4bc7a41fa87817ac0677
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
diff --git a/package/network/services/uhttpd/files/uhttpd.init b/package/network/services/uhttpd/files/uhttpd.init
index 379a9f5b5f..ad46d2c9b7 100755
--- a/package/network/services/uhttpd/files/uhttpd.init
+++ b/package/network/services/uhttpd/files/uhttpd.init
@@ -59,7 +59,7 @@ start_instance()
local cfg="$1"
local realm="$(uci_get system.@system[0].hostname)"
- local listen http https interpreter path
+ local listen http https interpreter indexes path
append_arg "$cfg" home "-h"
append_arg "$cfg" realm "-r" "${realm:-OpenWrt}"
@@ -71,7 +71,6 @@ start_instance()
append_arg "$cfg" network_timeout "-T"
append_arg "$cfg" tcp_keepalive "-A"
append_arg "$cfg" error_page "-E"
- append_arg "$cfg" index_page "-I"
append_arg "$cfg" max_requests "-n" 3
append_bool "$cfg" no_symlinks "-S" 0
@@ -88,6 +87,11 @@ start_instance()
append UHTTPD_ARGS "-i $path"
done
+ config_get indexes "$cfg" index_page
+ for path in $indexes; do
+ append UHTTPD_ARGS "-I $path"
+ done
+
config_get https "$cfg" listen_https
config_get UHTTPD_KEY "$cfg" key /etc/uhttpd.key
config_get UHTTPD_CERT "$cfg" cert /etc/uhttpd.crt