aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-22 07:08:39 +0000
commitf1da5431bb3e440f3d1337a8ec08cc09611a1550 (patch)
tree1f72522059329319cd185e32f50190e87f48969a /package
parent8b689d039739629ec24c86e47e4aa32e5b80f2bb (diff)
downloadupstream-f1da5431bb3e440f3d1337a8ec08cc09611a1550.tar.gz
upstream-f1da5431bb3e440f3d1337a8ec08cc09611a1550.tar.bz2
upstream-f1da5431bb3e440f3d1337a8ec08cc09611a1550.zip
build variants: only build opkg packages for the requested build variant (or any if no variant was specified for the package)
SVN-Revision: 18464
Diffstat (limited to 'package')
-rw-r--r--package/hostapd/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 5e10ea27b9..bb497fec3b 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -108,7 +108,7 @@ define Build/Compile
hostapd hostapd_cli
endef
-define Package/InstallTemplate
+define Package/hostapd/install
$(INSTALL_DIR) $(1)/etc/hotplug.d/net
$(INSTALL_DATA) ./files/hostapd.hotplug $(1)/etc/hotplug.d/net/
$(INSTALL_DIR) $(1)/lib/wifi
@@ -116,12 +116,7 @@ define Package/InstallTemplate
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
endef
-
-ifeq ($(BUILD_VARIANT),full)
- Package/hostapd/install = $(Package/InstallTemplate)
-else
- Package/hostapd-mini/install = $(Package/InstallTemplate)
-endif
+Package/hostapd-mini/install = $(Package/hostapd/install)
define Package/hostapd-utils/install
$(INSTALL_DIR) $(1)/usr/sbin