aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-09-20 13:20:21 +0200
committerPetr Štetiar <ynezz@true.cz>2019-11-14 20:59:58 +0100
commite1854815aa4e8d85cc7a831d665a8a43d00f41c0 (patch)
treeab6eb2e8dcd95b3d8b8129cb8568e1401d7505ec /package
parent3e9b3d0ba91abd097b30590a01cbd099a5d89f58 (diff)
downloadupstream-e1854815aa4e8d85cc7a831d665a8a43d00f41c0.tar.gz
upstream-e1854815aa4e8d85cc7a831d665a8a43d00f41c0.tar.bz2
upstream-e1854815aa4e8d85cc7a831d665a8a43d00f41c0.zip
hostapd: mirror ieee80211w ap mode defaults in station mode
For AP mode, OpenWrt automatically sets ieee80211w to either 1 or 2, depending on whether the encryption is set to sae-mixed, or sae/owe/eap suite-b. Mirror the same defaults for client mode connections, in order to allow an OpenWrt station to associate to an OpenWrt ap with SAE, OWE or Suite-B encryption without the need to manually specify "option ieee80211w" on the station. Signed-off-by: Jo-Philipp Wich <jo@mein.io> (cherry picked from commit abb4f4075e791789fdb00731035e08a8cf51555f)
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh9
2 files changed, 10 insertions, 1 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index e94d66211d..63e7a5dea1 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index 96cfc13a7d..fdbce815df 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -754,6 +754,15 @@ wpa_supplicant_add_network() {
ieee80211w ieee80211r \
multi_ap
+ case "$auth_type" in
+ sae|owe|eap192|eap-eap192)
+ set_default ieee80211w 2
+ ;;
+ psk-sae)
+ set_default ieee80211w 1
+ ;;
+ esac
+
set_default ieee80211r 0
set_default multi_ap 0