aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-24 21:33:35 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-24 21:33:35 +0000
commit98c5037127164e4906fdf94f24079f8a10bbc6dd (patch)
tree2d6b5e825ea7aae9dd5c1daea3fd65552fb36504 /package
parent51370f3b288c8c0da3e1b8dd4e57dacb955b0b5e (diff)
downloadupstream-98c5037127164e4906fdf94f24079f8a10bbc6dd.tar.gz
upstream-98c5037127164e4906fdf94f24079f8a10bbc6dd.tar.bz2
upstream-98c5037127164e4906fdf94f24079f8a10bbc6dd.zip
package/perf: move out to packages/devel/
SVN-Revision: 28560
Diffstat (limited to 'package')
-rw-r--r--package/perf/Makefile52
1 files changed, 0 insertions, 52 deletions
diff --git a/package/perf/Makefile b/package/perf/Makefile
deleted file mode 100644
index 0a78fa6277..0000000000
--- a/package/perf/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Copyright (C) 2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=perf
-PKG_RELEASE:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/perf
- SECTION:=utils
- CATEGORY:=Utilities
- DEPENDS:= +libdw +libelf1 +libpthread +librt @BROKEN
- TITLE:=Linux performance monitoring tool
- VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
- URL:=http://www.kernel.org
-endef
-
-define Package/perf/description
- perf is the Linux performance monitoring tool
-endef
-
-define Build/Prepare
-endef
-
-define Build/Compile
- $(MAKE) -C $(LINUX_DIR)/tools/perf \
- ARCH="$(LINUX_KARCH)" \
- NO_LIBPERL=1 \
- NO_LIBPYTHON=1 \
- NO_NEWT=1 \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- CC="$(TARGET_CC)" \
- LD="$(TARGET_CROSS)ld" \
- CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
- V=1 \
- prefix=/usr
-endef
-
-define Package/perf/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(LINUX_DIR)/tools/perf/perf $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,perf))