aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-11-23 17:12:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-11-23 17:12:54 +0000
commit79fcadc146717e489c9ea626b6c2c8f95c1de8c6 (patch)
tree4892adc317951fecfe7360c7d363cb8fcc9368a1 /package
parent0153a9bfea5204a4b72e0900ddcc97dfc244a27b (diff)
downloadupstream-79fcadc146717e489c9ea626b6c2c8f95c1de8c6.tar.gz
upstream-79fcadc146717e489c9ea626b6c2c8f95c1de8c6.tar.bz2
upstream-79fcadc146717e489c9ea626b6c2c8f95c1de8c6.zip
hostapd: fix rebuild checks (#6210)
SVN-Revision: 18497
Diffstat (limited to 'package')
-rw-r--r--package/hostapd/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index bb497fec3b..b1dde1c453 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -80,9 +80,19 @@ define Package/hostapd-utils/description
IEEE 802.1x/WPA/EAP/RADIUS Authenticator.
endef
-define Build/Configure
+ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
+ $(warning $(wildcard $(PKG_BUILD_DIR)/.config_*) != $(subst .configured_,.config_,$(STAMP_CONFIGURED)))
+ define Build/Configure/rebuild
rm -f $(PKG_BUILD_DIR)/hostapd/hostapd
+ rm -f $(PKG_BUILD_DIR)/hostapd/*.o
rm -f $(PKG_BUILD_DIR)/src/drivers/drivers.o
+ rm -f $(PKG_BUILD_DIR)/.config_*
+ touch $(subst .configured_,.config_,$(STAMP_CONFIGURED))
+ endef
+endif
+
+define Build/Configure
+ $(Build/Configure/rebuild)
$(CP) ./files/$(BUILD_VARIANT).config $(PKG_BUILD_DIR)/hostapd/.config
endef