aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-07-31 18:11:01 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-11-22 01:10:48 +0100
commit538ca42ddad8ff37676bf78b31e176fd5ca4f704 (patch)
treecd0872fe5c23bfed16a1e5afdf7a4362dd75280a /package
parent2751c5c7521930e22a8c01d66000ef0d9bfd6084 (diff)
downloadupstream-538ca42ddad8ff37676bf78b31e176fd5ca4f704.tar.gz
upstream-538ca42ddad8ff37676bf78b31e176fd5ca4f704.tar.bz2
upstream-538ca42ddad8ff37676bf78b31e176fd5ca4f704.zip
wireless-regdb: fix build when python2 from package feeds exists
wireless-regdb fails to build if there is python2 installed from package feeds, as staging_dir/hostpkg/bin/python is python2 and staging_dir/hostpkg/bin takes precedence over staging_dir/host/bin (proper place with python -> python3 symlink) which leads to the build failure of wireless-regdb, so this patch makes it explicit which python should be used. Reported-by: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk> Tested-by: Russell Senior <russell@personaltelco.net> Tested-by: Lucian Cristian <lucian.cristian@gmail.com> Signed-off-by: Petr Štetiar <ynezz@true.cz> (cherry picked from commit b6bae4a2c9f11f7e55319c2b4c709396ce649688)
Diffstat (limited to 'package')
-rw-r--r--package/firmware/wireless-regdb/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/firmware/wireless-regdb/Makefile b/package/firmware/wireless-regdb/Makefile
index 88a8d0bd9c..26f470af44 100644
--- a/package/firmware/wireless-regdb/Makefile
+++ b/package/firmware/wireless-regdb/Makefile
@@ -20,7 +20,7 @@ define Package/wireless-regdb
endef
define Build/Compile
- $(PYTHON) $(PKG_BUILD_DIR)/db2fw.py $(PKG_BUILD_DIR)/regulatory.db $(PKG_BUILD_DIR)/db.txt
+ $(STAGING_DIR_HOST)/bin/$(PYTHON) $(PKG_BUILD_DIR)/db2fw.py $(PKG_BUILD_DIR)/regulatory.db $(PKG_BUILD_DIR)/db.txt
endef
define Package/wireless-regdb/install