aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2018-11-09 12:09:29 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-11-10 18:50:29 +0100
commit1b4b942bcef8638a040788ab9ae94c66e38fd960 (patch)
tree60a65171bbf1a14cee1f4e43bf21cf5632000592 /package
parent5617e138bdaff94587d700def3d74e81c5b2db19 (diff)
downloadupstream-1b4b942bcef8638a040788ab9ae94c66e38fd960.tar.gz
upstream-1b4b942bcef8638a040788ab9ae94c66e38fd960.tar.bz2
upstream-1b4b942bcef8638a040788ab9ae94c66e38fd960.zip
Revert "iptables: fix dependency for libip6tc on IPV6"
This patch reverts commit 2dc1f54b1205094e7c6036cae6275d2c326bad3e as it breaks the build for me on x86-64 if I've IPV6 support disabled. Same config builds fine on `openwrt-18.06` branch at 55d078b2. $ grep IPV6 .config # CONFIG_KERNEL_IPV6 is not set # CONFIG_IPV6 is not set Build errors out on: Package libiptc is missing dependencies for the following libraries: libip6tc.so.0 Looking at iptables-1.6.2/libiptc/Makefile.am: libiptc_la_LIBADD = libip4tc.la libip6tc.la and to iptables-1.6.2/libiptc/libiptc.pc.in: Requires: libip4tc libip6tc It seems that libiptc needs v4/v6 libs, so v6 isn't optional. Cc: Rosy Song <rosysong@rosinson.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 2beaa7135e..4c5a581268 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -492,7 +492,7 @@ define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
+ DEPENDS:=+libip4tc +libip6tc +libxtables
ABI_VERSION:=$(PKG_VERSION)
TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
endef
@@ -512,7 +512,7 @@ $(call Package/iptables/Default)
CATEGORY:=Libraries
TITLE:=IPv6 firewall - shared libiptc library
ABI_VERSION:=$(PKG_VERSION)
- DEPENDS:=@IPV6 +libxtables
+ DEPENDS:=+libxtables
endef
define Package/libxtables