aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-12-28 21:22:04 +0100
committerPetr Štetiar <ynezz@true.cz>2020-01-05 17:50:10 +0100
commit04fd5e22b24259725a7932b3be0916c3fa750f64 (patch)
tree593313511fa68479c92b2f6d0df9d2f2b8111c52 /package
parentbf99f7920012a1b45e9e6d094e9ac1bcd1f7d931 (diff)
downloadupstream-04fd5e22b24259725a7932b3be0916c3fa750f64.tar.gz
upstream-04fd5e22b24259725a7932b3be0916c3fa750f64.tar.bz2
upstream-04fd5e22b24259725a7932b3be0916c3fa750f64.zip
libubox: update to version 2019-12-28
Contains following changes: cd75136b1342 blobmsg: fix wrong payload len passed from blobmsg_check_array eb7eb6393d47 blobmsg: fix array out of bounds GCC 10 warning 86f6a5b8d1f1 blobmsg: reuse blobmsg_namelen in blobmsg_data 586ce031eaa0 tests: fuzz: fuzz _len variants of checking methods b0e21553ae8c blobmsg: add _len variants for all attribute checking methods cd3059796a57 Replace use of blobmsg_check_attr by blobmsg_check_attr_len 143303149c8b Ensure blob_attr length check does not perform out of bounds reads f2b2ee441adb blobmsg: fix heap buffer overflow in blobmsg_parse 4dfd24ed88c4 blobmsg: make blobmsg_len and blobmsg_data_len return unsigned value 2df6d35e3299 tests: add test cases for blobmsg parsing 8a34788b46c4 test: fuzz: add blobmsg_check_attr crashes 478597b9f9ae blob: fix OOB access in blob_check_type 325418a7a3c0 tests: use blob_parse_untrusted variant 0b24e24b93e1 blob: introduce blob_parse_untrusted 6d27336e4a8b blob: refactor attr parsing into separate function 833d25797b16 test: fuzz: add blob_parse crashes 09ee90f8d6ed tests: add test cases for blob parsing 436d6363a10b tests: add libFuzzer based tests bf680707acfd tests: add unit tests covered with Clang sanitizers f804578847de cmake: add more hardening compiler flags 46f8268b4b5b blobmsg/ulog: fix format string compiler warnings eb216a952407 cmake: use extra compiler warnings only on gcc6+ 07413cce72e1 tests: jshn: add more test cases 26586dae43a8 jshn: fix missing usage for -p and -o arguments 8e832a771d3a jshn: fix off by one in jshn_parse_file cb698e35409b jshn: jshn_parse: fix leaks of memory pointed to by 'obj' c42f11cc7c0f jshn: main: fix leak of memory pointed to by 'vars' 93848ec96dc5 jshn: refactor main into smaller pieces 9b6ede0e5312 avl: guard against theoretical null pointer dereference c008294a8323 blobmsg_json: fix possible uninitialized struct member 0003ea9c45cc base64: fix possible null pointer dereference 8baeeea1f52d add assert.h component b0a5cd8a28bf add cram based unit tests 1fefb7c4d7f9 add initial GitLab CI support c955464d7a9b enable extra compiler checks 6228df9de91d iron out all extra compiler warnings and bumps ABI_VERSION to 20191228. Acked-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/libs/libubox/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index 8a0533ce4c..24b5b45068 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/libubox.git
-PKG_MIRROR_HASH:=58f6f6b21a00b69d466bcbce31e8adbef364d139715731430194746be5211840
-PKG_SOURCE_DATE:=2019-10-29
-PKG_SOURCE_VERSION:=301303911dded723b7eda4d6a4a933b22d2c1b60
+PKG_MIRROR_HASH:=90511058f49a178a816d520944cddba421f9eb50c319ef1623bed7aa22f94a3a
+PKG_SOURCE_DATE:=2019-12-28
+PKG_SOURCE_VERSION:=cd75136b1342e1e9dabf921be13240c6653640ed
CMAKE_INSTALL:=1
PKG_LICENSE:=ISC
@@ -27,7 +27,7 @@ define Package/libubox
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Basic utility library
- ABI_VERSION:=20170601
+ ABI_VERSION:=20191228
DEPENDS:=
endef