aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-05-14 09:47:26 +0200
committerPetr Štetiar <ynezz@true.cz>2019-05-20 21:19:48 +0200
commit049748e87e329313635cc7f7cc858a6c44eaf4f1 (patch)
treee6b055245ae4a20f20ddb9dc73c21e8d963f3c3a /package
parent4318bba0e94c034064f2ea3bf0a896d940227d66 (diff)
downloadupstream-049748e87e329313635cc7f7cc858a6c44eaf4f1.tar.gz
upstream-049748e87e329313635cc7f7cc858a6c44eaf4f1.tar.bz2
upstream-049748e87e329313635cc7f7cc858a6c44eaf4f1.zip
uboot-imx6: bump to 2019.04 and refresh patches
Build tested: apalis, mx6sabresd, nitrogen6dl, nitrogen6dl2g, nitrogen6q, nitrogen6q2g, nitrogen6s, nitrogen6s1g, wandboard Run tested: apalis Cc: Felix Fietkau <nbd@nbd.name> Cc: Vladimir Vid <vladimir.vid@sartura.hr> Cc: Koen Vandeputte <koen.vandeputte@ncentric.com> Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-imx6/Makefile4
-rw-r--r--package/boot/uboot-imx6/patches/0001-imx6-apalis-Make-the-boot-process-more-generic.patch14
-rw-r--r--package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch4
-rw-r--r--package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch2
4 files changed, 10 insertions, 14 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index f431afc525..193a35d27c 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -7,10 +7,10 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2019.01
+PKG_VERSION:=2019.04
PKG_RELEASE:=1
-PKG_HASH:=50bd7e5a466ab828914d080d5f6a432345b500e8fba1ad3b7b61e95e60d51c22
+PKG_HASH:=76b7772d156b3ddd7644c8a1736081e55b78828537ff714065d21dbade229bef
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-imx6/patches/0001-imx6-apalis-Make-the-boot-process-more-generic.patch b/package/boot/uboot-imx6/patches/0001-imx6-apalis-Make-the-boot-process-more-generic.patch
index b8e532c083..4de8ede39f 100644
--- a/package/boot/uboot-imx6/patches/0001-imx6-apalis-Make-the-boot-process-more-generic.patch
+++ b/package/boot/uboot-imx6/patches/0001-imx6-apalis-Make-the-boot-process-more-generic.patch
@@ -48,11 +48,9 @@ Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/configs/apalis_imx6.h | 26 +++++++++++++++++++++-----
2 files changed, 23 insertions(+), 5 deletions(-)
-diff --git a/configs/apalis_imx6_defconfig b/configs/apalis_imx6_defconfig
-index 133fc1a..279d39f 100644
--- a/configs/apalis_imx6_defconfig
+++ b/configs/apalis_imx6_defconfig
-@@ -39,6 +39,7 @@ CONFIG_CMD_DFU=y
+@@ -40,6 +40,7 @@ CONFIG_CMD_DFU=y
CONFIG_CMD_GPIO=y
CONFIG_CMD_I2C=y
CONFIG_CMD_MMC=y
@@ -60,7 +58,7 @@ index 133fc1a..279d39f 100644
CONFIG_CMD_USB=y
CONFIG_CMD_USB_SDP=y
CONFIG_CMD_USB_MASS_STORAGE=y
-@@ -48,6 +49,7 @@ CONFIG_CMD_PING=y
+@@ -49,6 +50,7 @@ CONFIG_CMD_PING=y
CONFIG_CMD_BMP=y
CONFIG_CMD_CACHE=y
CONFIG_CMD_EXT4=y
@@ -68,11 +66,9 @@ index 133fc1a..279d39f 100644
CONFIG_CMD_FAT=y
CONFIG_CMD_FS_GENERIC=y
CONFIG_ENV_IS_IN_MMC=y
-diff --git a/include/configs/apalis_imx6.h b/include/configs/apalis_imx6.h
-index 135b3c9..3601891 100644
--- a/include/configs/apalis_imx6.h
+++ b/include/configs/apalis_imx6.h
-@@ -142,9 +142,9 @@
+@@ -138,9 +138,9 @@
"imx6q-colibri-cam-eval-v3.dtb fat 0 1"
#define EMMC_BOOTCMD \
@@ -84,7 +80,7 @@ index 135b3c9..3601891 100644
"setenv bootargs ${defargs} ${emmcargs} ${setupargs} " \
"${vidargs}; echo Booting from internal eMMC chip...; " \
"run emmcdtbload; load mmc 0:1 ${kernel_addr_r} " \
-@@ -201,10 +201,17 @@
+@@ -197,10 +197,17 @@
#define FDT_FILE "imx6q-apalis_v1_0-eval.dtb"
#endif
#define CONFIG_EXTRA_ENV_SETTINGS \
@@ -104,7 +100,7 @@ index 135b3c9..3601891 100644
"boot_file=uImage\0" \
"console=ttymxc0\0" \
"defargs=enable_wait_mode=off vmalloc=400M\0" \
-@@ -232,7 +239,16 @@
+@@ -228,7 +235,16 @@
"vidargs=mxc_hdmi.only_cea=1 " \
"video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24 " \
"video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off " \
diff --git a/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch b/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
index 3ab61528f7..2fd207e11c 100644
--- a/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
+++ b/package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
@@ -1,6 +1,6 @@
--- a/configs/wandboard_defconfig
+++ b/configs/wandboard_defconfig
-@@ -29,7 +29,7 @@ CONFIG_CMD_I2C=y
+@@ -30,7 +30,7 @@ CONFIG_CMD_I2C=y
CONFIG_CMD_MMC=y
CONFIG_CMD_SATA=y
CONFIG_CMD_USB=y
@@ -9,7 +9,7 @@
CONFIG_CMD_EXT4_WRITE=y
CONFIG_ENV_IS_IN_MMC=y
CONFIG_ENV_VARS_UBOOT_RUNTIME_CONFIG=y
-@@ -43,3 +43,5 @@ CONFIG_USB=y
+@@ -44,3 +44,5 @@ CONFIG_USB=y
CONFIG_VIDEO=y
# CONFIG_VIDEO_SW_CURSOR is not set
CONFIG_OF_LIBFDT=y
diff --git a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch b/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
index 4b34a831ba..2b2fde5ec9 100644
--- a/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
+++ b/package/boot/uboot-imx6/patches/110-mx6cuboxi-mmc-fallback.patch
@@ -15,7 +15,7 @@
if (phydev->drv->config)
--- a/arch/arm/mach-imx/spl.c
+++ b/arch/arm/mach-imx/spl.c
-@@ -167,7 +167,7 @@ int g_dnl_bind_fixup(struct usb_device_d
+@@ -176,7 +176,7 @@ int g_dnl_bind_fixup(struct usb_device_d
/* called from spl_mmc to see type of boot mode for storage (RAW or FAT) */
u32 spl_boot_mode(const u32 boot_device)
{