aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorOldřich Jedlička <oldium.pro@gmail.com>2019-01-29 22:25:33 +0100
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-24 10:30:02 +0000
commita2fe698a40a76d693493b89fd929241093cf8ff4 (patch)
treed4e653644e491482ad3a43cba8f82c475a2724ea /package
parentdff0b2104d8403f888c3d0bebd70dce08d254dad (diff)
downloadupstream-a2fe698a40a76d693493b89fd929241093cf8ff4.tar.gz
upstream-a2fe698a40a76d693493b89fd929241093cf8ff4.tar.bz2
upstream-a2fe698a40a76d693493b89fd929241093cf8ff4.zip
kernel: Added required dependencies for socket match.
This applies to kernel 4.10 and newer. See https://github.com/torvalds/linux/commit/8db4c5be88f62ffd7a552f70687a10c614dc697b The above commit added to kernel 4.10 added new dependency for building the NETFILTER_XT_MATCH_SOCKET (xt_socket.ko) module. The NF_SOCKET_IPVx options (both of them) need to be enabled in order to build the NETFILTER_XT_MATCH_SOCKET module. Without the change the module is not built. Signed-off-by: Oldřich Jedlička <oldium.pro@gmail.com> (cherry picked from commit 66e875a07033cdcfd8c4a16940d4acfe63c60202) (required for fixing FS#2531) Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netfilter.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 3a989104d7..f2e10682b4 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -554,6 +554,8 @@ define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +IPV6:kmod-ip6tables
KCONFIG:= \
+ CONFIG_NF_SOCKET_IPV4 \
+ CONFIG_NF_SOCKET_IPV6 \
CONFIG_NETFILTER_XT_MATCH_SOCKET \
CONFIG_NETFILTER_XT_TARGET_TPROXY
FILES:= \