aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-10-30 12:41:34 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-30 12:47:17 +0000
commit700f66ae950053afe03eedf5d1c37fc7c8c7d906 (patch)
tree9b14789b1d5e632c0bc77fdafb46fe23ddb0ea55 /package
parentc4a2e5102d23dad98b09a8d5cd6192967bfc7206 (diff)
downloadupstream-700f66ae950053afe03eedf5d1c37fc7c8c7d906.tar.gz
upstream-700f66ae950053afe03eedf5d1c37fc7c8c7d906.tar.bz2
upstream-700f66ae950053afe03eedf5d1c37fc7c8c7d906.zip
kernel: mark kmod-usb-serial-wwan as hidden
The kconfig symbol is an invisible one since its introduction. It is not supposed to be enabled on its own. Resolves FS#1821 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> (cherry picked from commit 4bf9bec361699e1c033460964158531adf15d7ee)
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 0c5bb33f38..2bd5b390d2 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -852,6 +852,7 @@ define KernelPackage/usb-serial-wwan
TITLE:=Support for GSM and CDMA modems
KCONFIG:=CONFIG_USB_SERIAL_WWAN
FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko
+ HIDDEN:=1
AUTOLOAD:=$(call AutoProbe,usb_wwan)
$(call AddDepends/usb-serial)
endef
@@ -865,11 +866,10 @@ $(eval $(call KernelPackage,usb-serial-wwan))
define KernelPackage/usb-serial-option
TITLE:=Support for Option HSDPA modems
- DEPENDS:=+kmod-usb-serial-wwan
KCONFIG:=CONFIG_USB_SERIAL_OPTION
FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko
AUTOLOAD:=$(call AutoProbe,option)
- $(call AddDepends/usb-serial)
+ $(call AddDepends/usb-serial,+kmod-usb-serial-wwan)
endef
define KernelPackage/usb-serial-option/description