aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2019-08-13 03:01:07 -0300
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-17 17:23:17 +0200
commit5e3b21c91647f72e73a550f3059fa7ea8146759f (patch)
tree6b6d000fa65fbe64b3daf9582f218c35535c8058 /package
parent2df2b75208dce06dee02508c8d589fc5f540023d (diff)
downloadupstream-5e3b21c91647f72e73a550f3059fa7ea8146759f.tar.gz
upstream-5e3b21c91647f72e73a550f3059fa7ea8146759f.tar.bz2
upstream-5e3b21c91647f72e73a550f3059fa7ea8146759f.zip
musl: ldso/dlsym: fix mips returning undef dlsym
This happens only the second time a library is loaded by dlopen(). After lib1 is loaded, dlsym(lib1,"undef1") correctly resolves the undef symbol from lib1 dependencies. After the second library is loaded, dlsym(lib2,"undef1") was returning the address of "undef1" in lib2 instead of searching lib2 dependencies. Backporting upstream fix which now uses the same logic for relocation time and dlsym. Fixes openwrt/packages#9297 Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/libs/toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index febc7c2dbc..ac5f21d31a 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=toolchain
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_LICENSE:=GPL-3.0-with-GCC-exception