aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-02-25 13:05:59 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-02-25 13:05:59 +0000
commit280605c2d6707c65f49d7ecf3cb34556f55b9983 (patch)
tree1cf326af0ce1e9eb0dee0ccff80146f841c756a3 /package
parent1b7f0f3c0d8146673be5435166803b297ce13e3f (diff)
downloadupstream-280605c2d6707c65f49d7ecf3cb34556f55b9983.tar.gz
upstream-280605c2d6707c65f49d7ecf3cb34556f55b9983.tar.bz2
upstream-280605c2d6707c65f49d7ecf3cb34556f55b9983.zip
kernel: only depend on kmod-rtc-core if its provided by the used Kernel version
SVN-Revision: 30716
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ff42ebada5..9ab6700b7f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -751,7 +751,7 @@ $(eval $(call KernelPackage,rtc-core))
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support
- DEPENDS:=+kmod-rtc-core
+ DEPENDS:=+(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN):kmod-rtc-core
KCONFIG:=CONFIG_RTC_DRV_PCF8563
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf8563.ko
AUTOLOAD:=$(call AutoLoad,60,rtc-pcf8563)
@@ -768,7 +768,7 @@ $(eval $(call KernelPackage,rtc-pcf8563))
define KernelPackage/rtc-pcf2123
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF2123 RTC support
- DEPENDS:=+kmod-rtc-core
+ DEPENDS:=+(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN):kmod-rtc-core
KCONFIG:=CONFIG_RTC_DRV_PCF2123
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)