aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-03-01 18:38:55 +0100
committerHans Dedecker <dedeckeh@gmail.com>2018-03-02 09:48:41 +0100
commit175b2623288957dc7087278d1e78a7eedb077f8f (patch)
tree0c092c0f12d8268fc9e304b5d0ee26a5f75cab68 /package
parent9046e921aff8947600567134ad10d6451a1adaeb (diff)
downloadupstream-175b2623288957dc7087278d1e78a7eedb077f8f.tar.gz
upstream-175b2623288957dc7087278d1e78a7eedb077f8f.tar.bz2
upstream-175b2623288957dc7087278d1e78a7eedb077f8f.zip
netifd: add udhcpc link check to dhcp shell handler script
Fixes the assumption the busybox udhcpc applet is always enabled; in case the symbolic link check fails the DHCP shell handler script will exit and as result the DHCP protocol handler will not be registered in netifd. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package')
-rw-r--r--package/network/config/netifd/Makefile2
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/proto/dhcp.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 6e208ddd96..8b5d2f8ff3 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
diff --git a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
index afcfba9f49..a2b0ccedbf 100755
--- a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
+++ b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
@@ -1,5 +1,7 @@
#!/bin/sh
+[ -L /sbin/udhcpc ] || exit 0
+
. /lib/functions.sh
. ../netifd-proto.sh
init_proto "$@"