aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-01-10 12:26:28 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-10 13:44:24 +0100
commit96ade7adae9fc3a6c7940bce9152bee074348cec (patch)
treece3c3378c715b4a29cd0937807fd0aca4812308f /package
parent0b2b162db977cccb1d70b9a2625132120fe2e244 (diff)
downloadupstream-96ade7adae9fc3a6c7940bce9152bee074348cec.tar.gz
upstream-96ade7adae9fc3a6c7940bce9152bee074348cec.tar.bz2
upstream-96ade7adae9fc3a6c7940bce9152bee074348cec.zip
mpc85xx: build usb support into the kernel instead of packaging it separately
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk25
1 files changed, 2 insertions, 23 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 1d71c02e30..c226ae8b85 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -400,23 +400,6 @@ endef
$(eval $(call KernelPackage,usb-ohci-pci))
-define KernelPackage/usb2-fsl
- TITLE:=Support for Freescale USB2 controllers
- DEPENDS:=@TARGET_mpc85xx
- HIDDEN:=1
- KCONFIG:=CONFIG_USB_FSL_MPH_DR_OF
- FILES:=$(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
- AUTOLOAD:=$(call AutoLoad,39,fsl-mph-dr-of,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb2-fsl/description
- Kernel support for Freescale USB2 (EHCI) controllers
-endef
-
-$(eval $(call KernelPackage,usb2-fsl))
-
-
define KernelPackage/usb2-omap
TITLE:=Support for USB2 for OMAP
DEPENDS:=@TARGET_omap +kmod-usb-phy-nop +kmod-usb-phy-am335x +kmod-usb2
@@ -464,8 +447,7 @@ define KernelPackage/usb2
+TARGET_brcm47xx:kmod-usb-bcma \
+TARGET_brcm47xx:kmod-usb-ssb \
+TARGET_bcm53xx:kmod-usb-bcma \
- +TARGET_bcm53xx:kmod-phy-bcm-ns-usb2 \
- +TARGET_mpc85xx:kmod-usb2-fsl
+ +TARGET_bcm53xx:kmod-phy-bcm-ns-usb2
KCONFIG:=\
CONFIG_USB_EHCI_HCD \
CONFIG_USB_EHCI_ATH79=y \
@@ -486,10 +468,7 @@ define KernelPackage/usb2
ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko),)
FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-atmel.ko
endif
- ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko),)
- FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko
- endif
- AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel ehci-fsl,1)
+ AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion ehci-atmel,1)
$(call AddDepends/usb)
endef