aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-02-12 14:10:12 -0800
committerJo-Philipp Wich <jo@mein.io>2017-12-13 14:37:27 +0100
commitec395eeb172fa7cb5972279915b2ae1477c85582 (patch)
treeea75954bdfffb33789aaf1acdce0e82e162d7cbd /package
parentc6dd059a9a00db37c4d32eae1fe10635706bd8fc (diff)
downloadupstream-ec395eeb172fa7cb5972279915b2ae1477c85582.tar.gz
upstream-ec395eeb172fa7cb5972279915b2ae1477c85582.tar.bz2
upstream-ec395eeb172fa7cb5972279915b2ae1477c85582.zip
swconfig: Link with libubox
Fixes linking failures observed with external toolchains: /home/florian/dev/toolchains/stbgcc-4.8-1.5/bin/../lib/gcc/mipsel-linux-gnu/4.8.5/../../../../mipsel-linux-gnu/bin/ld: warning: libubox.so, needed by /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so, not found (try using -rpath or -rpath-link) /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blobmsg_open_nested' /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blobmsg_parse' /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blob_nest_end' /home/florian/dev/openwrt/trunk/staging_dir/target-mipsel-unknown-linux-gnu_glibc/usr/lib/libuci.so: undefined reference to `blobmsg_add_field' Signed-off-by: Florian Fainelli <f.fainelli@gmail.com> (cherry picked from commit fe8618a8fe0db1bc8f343c0f75082ff96e9991ab)
Diffstat (limited to 'package')
-rw-r--r--package/network/config/swconfig/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/config/swconfig/Makefile b/package/network/config/swconfig/Makefile
index e4a00d6d63..e457ce4882 100644
--- a/package/network/config/swconfig/Makefile
+++ b/package/network/config/swconfig/Makefile
@@ -34,7 +34,7 @@ define Build/Compile
CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
- LIBS="$(TARGET_LDFLAGS) -lnl-tiny -lm -luci"
+ LIBS="$(TARGET_LDFLAGS) -lnl-tiny -lm -luci -lubox"
endef
define Build/InstallDev