aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-08-04 13:09:12 +0200
committerJo-Philipp Wich <jo@mein.io>2017-12-13 16:48:35 +0100
commite5c284bb812a2342f678c854383267c166cf8678 (patch)
tree84896dd924dd96bc9af242e0d569e1bb28cf2fc2 /package
parentdde29b2b01e489184882fe718c4a3b9ffcfc3aac (diff)
downloadupstream-e5c284bb812a2342f678c854383267c166cf8678.tar.gz
upstream-e5c284bb812a2342f678c854383267c166cf8678.tar.bz2
upstream-e5c284bb812a2342f678c854383267c166cf8678.zip
package/elfutils: add CFLAG -Wno-format-nonliteral
When a library is using fortify-packages GCC will complain about "error: format not a string literal, argument types not checked". Signed-off-by: Alexander Couzens <lynxis@fe80.eu> (cherry picked from commit 6ab45214644166846398e5e520d151c05cc4dd55)
Diffstat (limited to 'package')
-rw-r--r--package/libs/elfutils/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 869513f16f..a726691d3a 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -68,7 +68,7 @@ endif
CONFIGURE_ARGS += \
--without-lzma
-TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result
+TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include