aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-08-16 20:33:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-08-16 20:33:55 +0000
commitd132f4c1c214997bf7c3979db193fcb05e4448bd (patch)
treeb824f903c66c92ce9f54c1caccf7a8d871cda058 /package
parentace8ce084517ec118b146f4732ba7382f98bc64f (diff)
downloadupstream-d132f4c1c214997bf7c3979db193fcb05e4448bd.tar.gz
upstream-d132f4c1c214997bf7c3979db193fcb05e4448bd.tar.bz2
upstream-d132f4c1c214997bf7c3979db193fcb05e4448bd.zip
add support for DS2482 1-Wire I2C bus master
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com> SVN-Revision: 28010
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/w1.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/w1.mk b/package/kernel/modules/w1.mk
index c4ab6165cc..c2bdd7099a 100644
--- a/package/kernel/modules/w1.mk
+++ b/package/kernel/modules/w1.mk
@@ -48,6 +48,23 @@ endef
$(eval $(call KernelPackage,w1-master-gpio))
+define KernelPackage/w1-master-ds2482
+ TITLE:=DS2482 1-wire i2c bus master driver
+ KCONFIG:=CONFIG_W1_MASTER_DS2482
+ FILES:=$(W1_MASTERS_DIR)/ds2482.ko
+ AUTOLOAD:=$(call AutoLoad,60,ds2482)
+ $(call AddDepends/w1,+kmod-i2c-core)
+endef
+
+define KernelPackage/w1-master-ds2482/description
+ Kernel module for the DS2482 i2c 1-wire bus master driver
+ NOTE: Init with: echo ds2482 0x18 > /sys/bus/i2c/devices/i2c-0/new_device
+ or use owfs
+endef
+
+$(eval $(call KernelPackage,w1-master-ds2482))
+
+
define KernelPackage/w1-master-ds2490
TITLE:=DS2490 1-wire usb bus master driver
DEPENDS:=@USB_SUPPORT +kmod-usb-core