aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-13 17:11:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-13 17:11:43 +0000
commit00808aaff32e58946f5da370068fd875aa3ae5c8 (patch)
treed027a624498e1fc7d7df224b5cfea8e4cd460106 /package
parent5ab66428b08fe1e9534be57ac8a9a99a5d85ce6e (diff)
downloadupstream-00808aaff32e58946f5da370068fd875aa3ae5c8.tar.gz
upstream-00808aaff32e58946f5da370068fd875aa3ae5c8.tar.bz2
upstream-00808aaff32e58946f5da370068fd875aa3ae5c8.zip
package/mac80211: add config option to enable Atheros wireless debugging
SVN-Revision: 18412
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 5e99342b79..13d1670a3e 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2009-11-03
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:= \
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/11 \
http://wireless.kernel.org/download/compat-wireless-2.6
@@ -278,10 +278,17 @@ config ATH_USER_REGD
help
Atheros' idea of regulatory handling is that the EEPROM of the card defines
the regulatory limits and the user is only allowed to restrict the settings
- even further, even if the country allows frequencies or power levels that
+ even further, even if the country allows frequencies or power levels that
are forbidden by the EEPROM settings.
Select this option if you want the driver to respect the user's decision about
regulatory settings.
+
+config PACKAGE_ATH_DEBUG
+ bool "Atheros wireless debugging"
+ depends on PACKAGE_kmod-ath
+ help
+ Say Y, if you want to debug atheros wireless drivers.
+ Right now only ath9k makes use of this.
endef
define KernelPackage/ath
@@ -492,6 +499,7 @@ BUILDFLAGS:= \
-DCONFIG_B43_HWRNG -DCONFIG_B43LEGACY_HWRNG \
$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),-DCONFIG_MAC80211_DEBUGFS) \
$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),-DCONFIG_ATH9K_DEBUG) \
+ $(if $(CONFIG_PACKAGE_ATH_DEBUG),-DCONFIG_ATH_DEBUG) \
-D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
$(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1)
@@ -518,6 +526,7 @@ MAKE_OPTS:= \
CONFIG_B43=$(if $(CONFIG_PACKAGE_kmod-b43),m) \
CONFIG_B43LEGACY=$(if $(CONFIG_PACKAGE_kmod-b43legacy),m) \
CONFIG_ATH_COMMON=$(if $(CONFIG_PACKAGE_kmod-ath),m) \
+ CONFIG_ATH_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \
CONFIG_ATH5K=$(if $(CONFIG_PACKAGE_kmod-ath5k),m) \
CONFIG_ATH9K=$(if $(CONFIG_PACKAGE_kmod-ath9k),m) \
CONFIG_ATH9K_DEBUG=$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),y) \