aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-12 17:45:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-12 17:45:22 +0000
commiteb3a4c760ad3a3d6b26840a633735458f76a19dd (patch)
tree1c7ea301a9b8c41b835699ff19ee80d058b23a61 /package
parent6d3fc477947331522c14a1b588f1ce8008ae5b6e (diff)
downloadupstream-eb3a4c760ad3a3d6b26840a633735458f76a19dd.tar.gz
upstream-eb3a4c760ad3a3d6b26840a633735458f76a19dd.tar.bz2
upstream-eb3a4c760ad3a3d6b26840a633735458f76a19dd.zip
only check prerequisites of actually selected packages
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5055 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/Makefile b/package/Makefile
index d2b7468a39..e94c181ba0 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/.config
include $(TOPDIR)/.pkgdeps
include $(TOPDIR)/host.mk
-PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(package-prereq))
+PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(prereq-y) $(prereq-m))
DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))