aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-05-14 09:28:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-05-14 09:28:34 +0000
commitc3b79909260137c9b84202b98f271bbeb8f0f7f1 (patch)
tree10a5cdf6b04a5b55946ed991c71434584895f1ac /package
parent3ff8d89328dc13358b9c2d7e74eed49bab5df227 (diff)
downloadupstream-c3b79909260137c9b84202b98f271bbeb8f0f7f1.tar.gz
upstream-c3b79909260137c9b84202b98f271bbeb8f0f7f1.tar.bz2
upstream-c3b79909260137c9b84202b98f271bbeb8f0f7f1.zip
RTCs shouldn't be modules, ever..
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15837 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk37
1 files changed, 0 insertions, 37 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index ac2824ed89..392a88ed0f 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -879,40 +879,3 @@ define KernelPackage/rfkill/description
endef
$(eval $(call KernelPackage,rfkill))
-
-
-define KernelPackage/rtc-core
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Kernel support for RTC devices
- DEPENDS:=@LINUX_2_6
- KCONFIG:= \
- CONFIG_RTC_CLASS \
- CONFIG_RTC_LIB \
- CONFIG_RTC_HCTOSYS=y \
- CONFIG_RTC_HCTOSYS_DEVICE=rtc0
- FILES:= \
- $(LINUX_DIR)/drivers/rtc/rtc-core.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/rtc/rtc-lib.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,30,rtc-lib rtc-core)
-endef
-
-define KernelPackage/rtc-core/description
- Kernel module for the RTC devices.
-endef
-
-$(eval $(call KernelPackage,rtc-core))
-
-define KernelPackage/rtc-m48t86
- SUBMENU:=$(OTHER_MENU)
- TITLE:=RTC M48T86 / Dallas DS12887
- DEPENDS:=+kmod-rtc-core
- KCONFIG:=CONFIG_RTC_DRV_M48T86
- FILES:=$(LINUX_DIR)/drivers/rtc/rtc-m48t86.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,31,rtc-m48t86)
-endef
-
-define KernelPackage/rtc-m48t86/description
- Kernel support for the RTC device M48T86 / Dallas DS12887
-endef
-
-$(eval $(call KernelPackage,rtc-m48t86))