aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2016-05-03 12:18:16 +0000
committerLuka Perkov <luka@openwrt.org>2016-06-19 19:56:13 +0200
commit8a170b96acd4e042d654138e7a7b1be2912e78bc (patch)
tree76c1df275338e69226e5fbe9c175de45c3e75983 /package
parente663db7bb1797740c4a29ac0fc96eda1b88f9e6e (diff)
downloadupstream-8a170b96acd4e042d654138e7a7b1be2912e78bc.tar.gz
upstream-8a170b96acd4e042d654138e7a7b1be2912e78bc.tar.bz2
upstream-8a170b96acd4e042d654138e7a7b1be2912e78bc.zip
CC: ubox: turn logd into a separate package
Currently system log is always included as a part of ubox. Add logd as a seperate package and add it to default packages list. Signed-off-by: Andrej Vlasic <andrej.vlasic@sartura.hr> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49294 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/system/ubox/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index d8a86c0732..cbd622e768 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -28,11 +28,17 @@ define Package/ubox
TITLE:=OpenWrt system helper toolbox
endef
+define Package/logd
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+libubox +libubus +libblobmsg-json +USE_GLIBC:librt
+ TITLE:=OpenWrt system log implementation
+endef
+
define Package/ubox/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/ $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{kmodloader,logd,logread,validate_data} $(1)/sbin/
- $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{kmodloader,validate_data} $(1)/sbin/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib
$(LN) ../../sbin/kmodloader $(1)/usr/sbin/rmmod
@@ -42,4 +48,12 @@ define Package/ubox/install
$(LN) ../../sbin/kmodloader $(1)/usr/sbin/modprobe
endef
+define Package/logd/install
+ $(INSTALL_DIR) $(1)/sbin $(1)/etc/init.d/
+
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{logd,logread} $(1)/sbin/
+ $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+endef
+
$(eval $(call BuildPackage,ubox))
+$(eval $(call BuildPackage,logd))