aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-04-14 07:16:59 +0000
committerNicolas Thill <nico@openwrt.org>2005-04-14 07:16:59 +0000
commit5c30d7013bdb8edacbdd9c291cba8d0fab5cfb7a (patch)
tree21cbaf53fd65d15a006b6131add5bbe07130efdf /package
parent0f6fa17345cb7d0bef02112e80c15d814d91dde3 (diff)
downloadupstream-5c30d7013bdb8edacbdd9c291cba8d0fab5cfb7a.tar.gz
upstream-5c30d7013bdb8edacbdd9c291cba8d0fab5cfb7a.tar.bz2
upstream-5c30d7013bdb8edacbdd9c291cba8d0fab5cfb7a.zip
Change searchpath from STAGING_DIR/{include,lib} to STAGING_DIR/usr/{include,lib},
Fix static libraries building git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/openssl/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index afa5f304e4..c33d412441 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -34,13 +34,17 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
(cd $(PKG_BUILD_DIR); \
CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5" \
PATH=$(TARGET_PATH) ./Configure linux-$(ARCH) --prefix=/ \
- --openssldir=/usr/lib/ssl -L$(STAGING_DIR)/lib -ldl \
- -I$(STAGING_DIR)/include $(OPENSSL_NO_CIPHERS) \
+ --openssldir=/usr/lib/ssl -L$(STAGING_DIR)/usr/lib -ldl \
+ -I$(STAGING_DIR)/usr/include $(OPENSSL_NO_CIPHERS) \
shared no-krb5 no-ec no-engine zlib-dynamic no-hw no-threads )
touch $(PKG_BUILD_DIR)/.configured
$(PKG_BUILD_DIR)/apps/openssl: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -j1 CC=$(TARGET_CC) -C $(PKG_BUILD_DIR) all build-shared
+ $(MAKE) -C $(PKG_BUILD_DIR) -j1 \
+ CC="$(TARGET_CC)" \
+ AR="$(TARGET_CROSS)ar r" \
+ RANLIB="$(TARGET_CROSS)ranlib" \
+ all build-shared
# Work around openssl build bug to link libssl.so with libcrypto.so.
-rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
$(MAKE) -j1 CC=$(TARGET_CC) -C $(PKG_BUILD_DIR) do_linux-shared