aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-08-26 13:11:56 +0000
committerJohn Crispin <blogic@openwrt.org>2014-08-26 13:11:56 +0000
commit427d705a65f1dbe1516d7b49a66ef261ad779c60 (patch)
tree496697db47c60f68c750cd9c6aa4aa28777b359b /package
parent72ee1edd7dad9750f3d84415d3875b2dfec7617f (diff)
downloadupstream-427d705a65f1dbe1516d7b49a66ef261ad779c60.tar.gz
upstream-427d705a65f1dbe1516d7b49a66ef261ad779c60.tar.bz2
upstream-427d705a65f1dbe1516d7b49a66ef261ad779c60.zip
kernel: add package for huawei ncm modems
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42304 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 0b5abdc335..d47c74623b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1215,6 +1215,21 @@ endef
$(eval $(call KernelPackage,usb-net-cdc-ncm))
+define KernelPackage/usb-net-huawei-cdc-ncm
+ TITLE:=Support for Huawei CDC NCM connections
+ KCONFIG:=CONFIG_USB_NET_HUAWEI_CDC_NCM
+ FILES:= $(LINUX_DIR)/drivers/$(USBNET_DIR)/huawei_cdc_ncm.ko
+ AUTOLOAD:=$(call AutoProbe,huawei_cdc_ncm)
+ $(call AddDepends/usb-net,+kmod-usb-wdm @(LINUX_3_13||LINUX_3_14))
+endef
+
+define KernelPackage/usb-net-huawei-cdc-ncm/description
+ Kernel support for Huawei CDC NCM connections
+endef
+
+$(eval $(call KernelPackage,usb-net-huawei-cdc-ncm))
+
+
define KernelPackage/usb-net-sierrawireless
TITLE:=Support for Sierra Wireless devices
KCONFIG:=CONFIG_USB_SIERRA_NET