aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-03-19 11:01:06 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-03-19 11:01:06 +0000
commit387d2ad4890d7f5b3d50beee5c248b9ad7b5f19d (patch)
tree7f2bf4cf5540516086a43a08195d7a475afb3531 /package
parent3b8cd0e6ca9fa61b282ebda2731d29dbd7724043 (diff)
downloadupstream-387d2ad4890d7f5b3d50beee5c248b9ad7b5f19d.tar.gz
upstream-387d2ad4890d7f5b3d50beee5c248b9ad7b5f19d.tar.bz2
upstream-387d2ad4890d7f5b3d50beee5c248b9ad7b5f19d.zip
CC: linux-firmware: fix rt73-usb-firmware package
Backport of r49037 Some parts of this package were named rt73-pci-firmware before which looks like a copy and past error. This renames all parts to rt73-usb- firmware and then the firmware gets build and the dependencies from the package with the kernel module are also working correctly. This fixes #22069 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@49038 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/firmware/linux-firmware/mediatek.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/firmware/linux-firmware/mediatek.mk b/package/firmware/linux-firmware/mediatek.mk
index 591ffee735..b258551a00 100644
--- a/package/firmware/linux-firmware/mediatek.mk
+++ b/package/firmware/linux-firmware/mediatek.mk
@@ -35,9 +35,9 @@ define Package/rt61-pci-firmware/install
endef
$(eval $(call BuildPackage,rt61-pci-firmware))
-Package/rt73-pci-firmware = $(call Package/firmware-default,Ralink RT2573 firmware)
+Package/rt73-usb-firmware = $(call Package/firmware-default,Ralink RT2573 firmware)
define Package/rt73-usb-firmware/install
$(INSTALL_DIR) $(1)/lib/firmware
$(INSTALL_DATA) $(PKG_BUILD_DIR)/rt73.bin $(1)/lib/firmware/
endef
-$(eval $(call BuildPackage,rt73-pci-firmware))
+$(eval $(call BuildPackage,rt73-usb-firmware))