aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-06-11 14:10:45 +0000
committerSteven Barth <steven@midlink.org>2013-06-11 14:10:45 +0000
commitf8cb31d28afe0a0efaeeb888dd06ef21f9f94a06 (patch)
tree5719db383ea86c6b9c1f53dadd090758a9e8b411 /package
parenteda688921ae6794e52c4d543824dd8f1ace2119c (diff)
downloadupstream-f8cb31d28afe0a0efaeeb888dd06ef21f9f94a06.tar.gz
upstream-f8cb31d28afe0a0efaeeb888dd06ef21f9f94a06.tar.bz2
upstream-f8cb31d28afe0a0efaeeb888dd06ef21f9f94a06.zip
base-files: remove unnecessary early sysctl-hack
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36920 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot7
2 files changed, 1 insertions, 8 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index f06c12fcb5..ec008c5ef0 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=140
+PKG_RELEASE:=141
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index 4f35eac7b3..d33e8ce7f8 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -72,11 +72,4 @@ start() {
rootdev=$(awk 'BEGIN { RS=" "; FS="="; } $1 == "root" { print $2 }' < /proc/cmdline)
[ -n "$rootdev" ] && ln -s "$rootdev" /dev/root
}
-
- # early sysctl to avoid networking races
- if [ -d /proc/sys/net/ipv6/conf ]; then
- for i in /proc/sys/net/ipv6/conf/*/accept_ra; do
- echo 0 > $i
- done
- fi
}