aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 21:16:21 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 21:16:21 +0000
commite590b621b07c6669e41976b3e49b1937b3189ee8 (patch)
tree3457a9e7d8543979a1046ca05c7f9321862dc864 /package
parentdf72f38897c73736e2bb7d00861f07fdf9bee67e (diff)
downloadupstream-e590b621b07c6669e41976b3e49b1937b3189ee8.tar.gz
upstream-e590b621b07c6669e41976b3e49b1937b3189ee8.tar.bz2
upstream-e590b621b07c6669e41976b3e49b1937b3189ee8.zip
package/kernel: add package for the PCF2123 RTC driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29664 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 266aa01cb8..62bc4e8a0d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -765,6 +765,22 @@ endef
$(eval $(call KernelPackage,rtc-pcf8563))
+define KernelPackage/rtc-pcf2123
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Philips PCF2123 RTC support
+ DEPENDS:=+kmod-rtc-core
+ KCONFIG:=CONFIG_RTC_DRV_PCF2123
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
+ AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)
+endef
+
+define KernelPackage/rtc-pcf2123/description
+ Kernel module for Philips PCF2123 RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pcf2123))
+
+
define KernelPackage/n810bm
SUBMENU:=$(OTHER_MENU)
TITLE:=Nokia N810 battery management driver