aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-28 02:35:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-28 02:35:45 +0000
commitdacb54ca3bbd3fee1d7ee50913a13637dd6e51b1 (patch)
tree7b59487c9532ca298aa844830c9923f497a6911b /package
parent767955134f8ba9ae27d9c5aa5a5fc7843c71bf02 (diff)
downloadupstream-dacb54ca3bbd3fee1d7ee50913a13637dd6e51b1.tar.gz
upstream-dacb54ca3bbd3fee1d7ee50913a13637dd6e51b1.tar.bz2
upstream-dacb54ca3bbd3fee1d7ee50913a13637dd6e51b1.zip
[package] uhttpd: fix parameter parsing issue on avr32 and most likely ixp4xx
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20532 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/uhttpd/Makefile3
-rw-r--r--package/uhttpd/src/uhttpd.c2
2 files changed, 3 insertions, 2 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 2b7714d30f..4bee17d234 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
@@ -56,6 +56,7 @@ endef
# hack to use CyASSL headers
TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+TARGET_LDFLAGS += -lm
MAKE_VARS += FPIC="$(FPIC)"
define Build/Prepare
diff --git a/package/uhttpd/src/uhttpd.c b/package/uhttpd/src/uhttpd.c
index be13b536d7..c6a8b6c272 100644
--- a/package/uhttpd/src/uhttpd.c
+++ b/package/uhttpd/src/uhttpd.c
@@ -422,7 +422,7 @@ int main (int argc, char **argv)
int nofork = 0;
/* args */
- char opt;
+ int opt;
char bind[128];
char *port = NULL;