aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-18 16:02:18 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-18 16:02:18 +0000
commitb7f6442aeb5f42969f7d6a7a6d05c1eadbf61e32 (patch)
treed3cb92dfc64fec6fbc15dca1fd8a34c4ebd0e488 /package
parentb19b30535607a53552f98fe876a77a6564cf1319 (diff)
downloadupstream-b7f6442aeb5f42969f7d6a7a6d05c1eadbf61e32.tar.gz
upstream-b7f6442aeb5f42969f7d6a7a6d05c1eadbf61e32.tar.bz2
upstream-b7f6442aeb5f42969f7d6a7a6d05c1eadbf61e32.zip
package/kernel: add package for MTD testing modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30628 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 62bc4e8a0d..ff42ebada5 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -796,3 +796,25 @@ define KernelPackage/n810bm/description
endef
$(eval $(call KernelPackage,n810bm))
+
+
+define KernelPackage/mtdtests
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=MTD subsystem tests
+ KCONFIG:=CONFIG_MTD_TESTS
+ FILES:=\
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_nandecctest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_oobtest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_pagetest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_readtest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_speedtest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_stresstest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_subpagetest.ko \
+ $(LINUX_DIR)/drivers/mtd/tests/mtd_torturetest.ko
+endef
+
+define KernelPackage/mtdtests/description
+ Kernel modules for MTD subsystem/driver testing.
+endef
+
+$(eval $(call KernelPackage,mtdtests))