aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-02 18:17:44 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-02 18:17:44 +0000
commitaa6eaba62356b2d4fe46400d326d68f05f205c4b (patch)
tree3a8e779366679ed65c432598966b5a677cc92a7e /package
parent79ba645f994878d04f1099ff6400396b9345904b (diff)
downloadupstream-aa6eaba62356b2d4fe46400d326d68f05f205c4b.tar.gz
upstream-aa6eaba62356b2d4fe46400d326d68f05f205c4b.tar.bz2
upstream-aa6eaba62356b2d4fe46400d326d68f05f205c4b.zip
mac80211: b43: make B43_PHY_LP configurable
This allows saving 11772 B if disabled. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40984 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 028929f4b6..a328d61cef 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1208,6 +1208,16 @@ define KernelPackage/b43/config
If unsure, say Y.
+ config PACKAGE_B43_PHY_LP
+ bool "Enable support for LP-PHYs"
+ default y
+ help
+ Enable support for LP-PHY. This includes support for the following devices:
+ PCI: BCM4312
+ SoC: BCM5354
+
+ If unsure, say Y.
+
config PACKAGE_B43_PHY_HT
bool "Enable support for HT-PHYs"
default y
@@ -1418,8 +1428,9 @@ endif
config-$(call config_package,carl9170) += CARL9170
config-$(call config_package,b43) += B43
-config-y += B43_SSB B43_BCMA B43_PHY_LP
+config-y += B43_SSB B43_BCMA
config-$(CONFIG_PACKAGE_B43_PHY_N) += B43_PHY_N
+config-$(CONFIG_PACKAGE_B43_PHY_LP) += B43_PHY_LP
config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
config-$(CONFIG_PACKAGE_B43_DEBUG) += B43_DEBUG