aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-10 16:13:43 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-10 16:13:43 +0000
commit6b00f788245a328dd4e2c25f3be277ecb9981227 (patch)
treeb81318b4b83ea6b4cdfa8f5e274b934b63cd77f8 /package
parent8048f460b04f123b858438e183fc0160cd94932e (diff)
downloadupstream-6b00f788245a328dd4e2c25f3be277ecb9981227.tar.gz
upstream-6b00f788245a328dd4e2c25f3be277ecb9981227.tar.bz2
upstream-6b00f788245a328dd4e2c25f3be277ecb9981227.zip
Fix building when host and target systems are same arch,
Always disable readline support git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1599 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/osiris/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/osiris/Makefile b/package/osiris/Makefile
index b119f6e039..152fcf46e5 100644
--- a/package/osiris/Makefile
+++ b/package/osiris/Makefile
@@ -23,7 +23,7 @@ $(PKG_BUILD_DIR)/.configured:
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
+ LDFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib" \
ac_cv_openssldir="$(STAGING_DIR)/usr" \
ac_cv_have_accrights_in_msghdr=no \
ac_cv_have_control_in_msghdr=yes \
@@ -49,6 +49,7 @@ $(PKG_BUILD_DIR)/.configured:
$(DISABLE_NLS) \
--with-osiris-user=root \
--with-root-dir=/var/lib/osiris \
+ --with-readline=no \
);
touch $@
@@ -56,6 +57,8 @@ $(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
+ ar=$(TARGET_CROSS)ar \
DESTDIR="$(PKG_INSTALL_DIR)" \
INTERACTIVE=0 \
all install